# Add EC2 host in sandbox

**URL:** <https://forum.opennebula.io/t/add-ec2-host-in-sandbox/716>\
**Category:** Product Support\
**Created:** [May 12, 2015, 10:05am UTC](https://forum.opennebula.io/t/add-ec2-host-in-sandbox/716 "2015-05-12T10:05:11Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![sbc](https://avatars.discourse-cdn.com/v4/letter/s/dc4da7/32.png) [@sbc](https://forum.opennebula.io/u/sbc)\
**Post date:** [May 12, 2015, 10:05am UTC](https://forum.opennebula.io/t/add-ec2-host-in-sandbox/716/1 "2015-05-12T10:05:11Z")

</div>

Dear comunity,

I try to add i try to add an ec2 host on my OpenNebula 4.12.0 virutal sandbox. Always receive an error message:

```
> Error monitoring Host ec2 (4): Error executing poll

```

/var/log/one/oned.log →

> Tue May 12 09:52:23 2015 [Z0][InM][D]: Monitoring datastore default (1)  
> Tue May 12 09:52:23 2015 [Z0][InM][D]: Monitoring datastore files (2)  
> Tue May 12 09:52:23 2015 [Z0][InM][D]: Monitoring host ec2 (4)  
> Tue May 12 09:52:23 2015 [Z0][ImM][D]: Datastore default (1) successfully monitored.  
> Tue May 12 09:52:23 2015 [Z0][ImM][D]: Datastore files (2) successfully monitored.  
> Tue May 12 09:52:23 2015 [Z0][InM][I]: Command execution fail: /var/lib/one/remotes/im/run\_probes ec2 /var/lib/one//datastores 4124 20 4 ec2  
> Tue May 12 09:52:23 2015 [Z0][InM][I]: /usr/lib/ruby/site\_ruby/1.8/rubygems/custom\_require.rb:31:in `gem_original_require': /usr/lib/ruby/gems/1.8/gems/aws-sdk-resources-2.0.29/lib/aws-sdk-resources.rb:29: syntax error, unexpected ':', expecting ')' (SyntaxError) Tue May 12 09:52:23 2015 [Z0][InM][I]: ...json(definition), source_path: definition) Tue May 12 09:52:23 2015 [Z0][InM][I]: ^ Tue May 12 09:52:23 2015 [Z0][InM][I]: /usr/lib/ruby/gems/1.8/gems/aws-sdk-resources-2.0.29/lib/aws-sdk-resources.rb:44: syntax error, unexpected kEND, expecting $end Tue May 12 09:52:23 2015 [Z0][InM][I]: from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require’  
> Tue May 12 09:52:23 2015 [Z0][InM][I]: from /usr/lib/ruby/gems/1.8/gems/aws-sdk-2.0.29/lib/aws-sdk.rb:1  
> Tue May 12 09:52:23 2015 [Z0][InM][I]: from /usr/lib/ruby/site\_ruby/1.8/rubygems/custom\_require.rb:36:in `gem_original_require' Tue May 12 09:52:23 2015 [Z0][InM][I]: from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require’  
> Tue May 12 09:52:23 2015 [Z0][InM][I]: from ./…/…/vmm/ec2/ec2\_driver.rb:34  
> Tue May 12 09:52:23 2015 [Z0][InM][I]: from ./poll:21:in `require’  
> Tue May 12 09:52:23 2015 [Z0][InM][I]: from ./poll:21  
> Tue May 12 09:52:23 2015 [Z0][InM][E]: Error executing poll  
> Tue May 12 09:52:23 2015 [Z0][InM][I]: ExitCode: 1  
> Tue May 12 09:52:23 2015 [Z0][ONE][E]: Error monitoring Host ec2 (4): Error executing poll

/etc/one/ec2\_driver.conf →

> proxy\_uri:  
> regions:  
> default:  
> region\_name: eu-west-1  
> access\_key\_id:AKIAXXXXXXXXXXXXXXXXXXXWA  
> secret\_access\_key:EMNXXXXXXXXXXXXXXXXXXXXXXXXXXur00LL  
> capacity:  
> m1.small:5  
> m1.large:0  
> m1.xlarge:0  
> us-east-1:

Thanks for assistance

---

<div class="post-metadata">

**Author:** ![dmolina](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/dmolina/32/22_2.png) [@dmolina](https://forum.opennebula.io/u/dmolina)\
**Post date:** [May 14, 2015, 7:52am UTC](https://forum.opennebula.io/t/add-ec2-host-in-sandbox/716/2 "2015-05-14T07:52:40Z")

</div>

Hi,

Probably, the problem is the missing whitespace between the key and the value in the access and secret keys.

Cheers

---

<div class="post-metadata">

**Author:** ![sbc](https://avatars.discourse-cdn.com/v4/letter/s/dc4da7/32.png) [@sbc](https://forum.opennebula.io/u/sbc)\
**Post date:** [May 14, 2015, 11:34am UTC](https://forum.opennebula.io/t/add-ec2-host-in-sandbox/716/3 "2015-05-14T11:34:25Z")

</div>

Hi,

i try with whitespace and without whitespace.

The key’s works fine with hybridfox.

**On a fresh virtualbox sandbox or AMI sandbox** i follow de instruccion of the driver configuration.

> **OpenNebula Configuration**

> Uncomment the EC2 IM and VMM drivers from /etc/one/oned.conf file in order to use the driver.

> IM\_MAD = [  
> name = “ec2”,  
> executable = “one\_im\_sh”,  
> arguments = “-c -t 1 -r 0 ec2” ]

> VM\_MAD = [  
> name = “ec2”,  
> executable = “one\_vmm\_sh”,  
> arguments = “-t 15 -r 0 ec2”,  
> type = “xml” ]

> /etc/one/ec2\_driver.conf:

> regions:  
> default:  
> region\_name: us-east-1  
> access\_key\_id: YOUR\_ACCESS\_KEY  
> secret\_access\_key: YOUR\_SECRET\_ACCESS\_KEY  
> capacity:  
> m1.small: 5  
> m1.large: 0  
> m1.xlarge: 0  
> After OpenNebula is restarted, create a new Host that uses the ec2 drivers:

> $ onehost create ec2 --im ec2 --vm ec2 --net dummy

/var/log/one/oned.log–\>

> Monitoring host ec2 (8)  
> Thu May 14 13:06:58 2015 [Z0][InM][I]: Command execution fail: **/var/lib/one/remotes/im/run\_probes ec2 /var/lib/one//datastores 4124 20 8 ec2**  
> Thu May 14 13:06:58 2015 [Z0][InM][I]: /usr/lib/ruby/site\_ruby/1.8/rubygems/custom\_require.rb:31:in `gem_original_require': /usr/lib/ruby/gems/1.8/gems/aws-sdk-resources-2.0.29/lib/aws-sdk-resources.rb:29: syntax error, unexpected ':', expecting ')' (SyntaxError) Thu May 14 13:06:58 2015 [Z0][InM][I]: ...json(definition), source_path: definition) Thu May 14 13:06:58 2015 [Z0][InM][I]: ^ Thu May 14 13:06:58 2015 [Z0][InM][I]: /usr/lib/ruby/gems/1.8/gems/aws-sdk-resources-2.0.29/lib/aws-sdk-resources.rb:44: syntax error, unexpected kEND, expecting $end Thu May 14 13:06:58 2015 [Z0][InM][I]: from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require’  
> Thu May 14 13:06:58 2015 [Z0][InM][I]: from /usr/lib/ruby/gems/1.8/gems/aws-sdk-2.0.29/lib/aws-sdk.rb:1  
> Thu May 14 13:06:58 2015 [Z0][InM][I]: from /usr/lib/ruby/site\_ruby/1.8/rubygems/custom\_require.rb:36:in `gem_original_require' Thu May 14 13:06:58 2015 [Z0][InM][I]: from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require’  
> Thu May 14 13:06:58 2015 [Z0][InM][I]: from ./…/…/vmm/ec2/ec2\_driver.rb:34  
> Thu May 14 13:06:58 2015 [Z0][InM][I]: from ./poll:21:in `require’  
> Thu May 14 13:06:58 2015 [Z0][InM][I]: from ./poll:21

Any Idea.

Thanks.

---

<div class="post-metadata">

**Author:** ![dmolina](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/dmolina/32/22_2.png) [@dmolina](https://forum.opennebula.io/u/dmolina)\
**Post date:** [May 18, 2015, 9:08am UTC](https://forum.opennebula.io/t/add-ec2-host-in-sandbox/716/4 "2015-05-18T09:08:13Z")

</div>

Hi,

Probably the problem is that you are using the last version (2) of the aws ruby sdk with ruby 1.8. Could you try removing this gem and installing a version \< 2:  
[https://github.com/aws/aws-sdk-ruby/tree/aws-sdk-v1](https://github.com/aws/aws-sdk-ruby/tree/aws-sdk-v1)

Hope this helps

---

<div class="post-metadata">

**Author:** ![juan\_freyre](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/juan_freyre/32/4370_2.png) [@juan\_freyre](https://forum.opennebula.io/u/juan_freyre)\
**Post date:** [May 19, 2015, 1:37pm UTC](https://forum.opennebula.io/t/add-ec2-host-in-sandbox/716/5 "2015-05-19T13:37:23Z")

</div>

i have the same problem just i not using the sandbox

i have a ESX server and opennebula with this server

now im trying with the ec2 host and i have the same problem.

have you fixed it ?

---

<div class="post-metadata">

**Author:** ![dmolina](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/dmolina/32/22_2.png) [@dmolina](https://forum.opennebula.io/u/dmolina)\
**Post date:** [May 20, 2015, 9:01am UTC](https://forum.opennebula.io/t/add-ec2-host-in-sandbox/716/6 "2015-05-20T09:01:32Z")

</div>

What ruby version are you using in the frontend (oned)?

---

<div class="post-metadata">

**Author:** ![sbc](https://avatars.discourse-cdn.com/v4/letter/s/dc4da7/32.png) [@sbc](https://forum.opennebula.io/u/sbc)\
**Post date:** [May 20, 2015, 11:13am UTC](https://forum.opennebula.io/t/add-ec2-host-in-sandbox/716/8 "2015-05-20T11:13:28Z")

</div>

Hi, yes, now connect to aws:.

> # gem install aws-sdk-v1

> # gem uninstall aws-sdk

> Select gem to uninstall:
> 
> 1. aws-sdk-1.33.0
> 2. aws-sdk-1.50.0
> 3. aws-sdk-1.57.0
> 4. aws-sdk-2.0.29
> 5. All versions  
> 4
