# Azure Driver - Error creating Azure Host

**URL:** https://forum.opennebula.io/t/azure-driver-error-creating-azure-host/3779
**Category:** Integration Support
**Created:** [February 13, 2017, 2:48pm UTC](https://forum.opennebula.io/t/azure-driver-error-creating-azure-host/3779 "2017-02-13T14:48:48Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![Senthil\_Panchatchara](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/senthil_panchatchara/32/5051_2.png) [@Senthil\_Panchatchara](https://forum.opennebula.io/u/Senthil_Panchatchara)
#### Post date: [February 13, 2017, 2:48pm UTC](https://forum.opennebula.io/t/azure-driver-error-creating-azure-host/3779/1 "2017-02-13T14:48:48Z")

</div>

I am following the documentation towards cloud bursting to Azure here [http://docs.opennebula.org/5.0/advanced\_components/cloud\_bursting/azg.html](http://docs.opennebula.org/5.0/advanced_components/cloud_bursting/azg.html).

Getting an Error after the host is created. I understand monitoring Azure is not supported. So went ahead creating an Azure VM Template, but the deployment fails with Error

Fri Feb 10 09:54:21 2017 [Z0][VMM][I]: /usr/local/share/gems/gems/azure-0.7.6/lib/azure/configurable.rb:184:in `rescue in management\_certificate=': Management certificate not valid. Error: PKCS12\_parse: mac verify failure (ArgumentError)

I am not linux expert or Ruby. The question is before proceeding with cloud integration should i need to have the password less (SSH login) enabled?

Can some one help me?

---

<div class="post-metadata">

### Author: ![tinova](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/tinova/32/25_2.png) [@tinova](https://forum.opennebula.io/u/tinova)
#### Post date: [February 13, 2017, 6:29pm UTC](https://forum.opennebula.io/t/azure-driver-error-creating-azure-host/3779/2 "2017-02-13T18:29:01Z")

</div>

The error you are experiencing refers to the management certificate not being correctly formed. Are you following the openssl commands to create the certificate? Could you share your /etc/one/az\_driver.conf?

You don’t need password less SSH login working for the Azure integration.

---

<div class="post-metadata">

### Author: ![Senthil\_Panchatchara](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/senthil_panchatchara/32/5051_2.png) [@Senthil\_Panchatchara](https://forum.opennebula.io/u/Senthil_Panchatchara)
#### Post date: [February 13, 2017, 7:11pm UTC](https://forum.opennebula.io/t/azure-driver-error-creating-azure-host/3779/3 "2017-02-13T19:11:23Z")

</div>

Tinova,

Thanks for following up. Here is the config file. I am trying to deploy the host to east-us, so filled in only that section and the default.

Here is the az\_driver.conf file. I had created the openssl cert using the root account. Will that be an issue?

proxy\_uri:  
regions:  
default:  
region\_name: “East US”  
# pem\_management\_cert --\> Absolute path to pem management certificate  
# Info on creating certificates:  
# [http://azure.microsoft.com/en-us/documentation/articles/linux-use-ssh-key/](http://azure.microsoft.com/en-us/documentation/articles/linux-use-ssh-key/)  
pem\_management\_cert: /root/myCert.pem  
subscription\_id: "de870d3e-7db7-484d-bf51-2dc44de4b081"  
management\_endpoint: "[https://management.core.windows.net](https://management.core.windows.net)"  
capacity:  
Small: 5  
Medium: 1  
Large: 0  
west-europe:  
region\_name: "West Europe"  
pem\_management\_cert:  
subscription\_id:  
management\_endpoint:  
capacity:  
Small: 5  
Medium: 1  
Large: 0  
north-europe:  
region\_name: "North Europe"  
pem\_management\_cert:  
subscription\_id:  
management\_endpoint:  
capacity:  
Small:  
Medium:  
Large:  
east-us:  
region\_name: "East US"  
pem\_management\_cert: /root/myCert.pem  
subscription\_id: "de870d3e-7db7-484d-bf51-2dc44de4b081"  
management\_endpoint: "[https://management.core.windows.net](https://management.core.windows.net)"  
capacity:  
Small: 5  
Medium: 1  
Large:  
south-central-us:  
region\_name: "South Central US"  
pem\_management\_cert:  
subscription\_id:  
management\_endpoint:  
capacity:  
Small:  
Medium:  
Large:  
west-us:  
region\_name: "West US"  
pem\_management\_cert:  
subscription\_id:  
management\_endpoint:  
capacity:  
Small:  
Medium:  
Large:  
east-asia:  
region\_name: "East Asia"  
pem\_management\_cert:  
subscription\_id:  
management\_endpoint:  
capacity:  
Small:  
Medium:  
Large:  
southeast-asia:  
region\_name: "Southeast Asia"  
pem\_management\_cert:  
subscription\_id:  
management\_endpoint:  
capacity:  
Small:  
Medium:  
Large:  
japan-west:  
region\_name: "Japan West"  
pem\_management\_cert:  
subscription\_id:  
management\_endpoint:  
capacity:  
Small:  
Medium:  
Large:  
brazil-south:  
region\_name: "Brazil South"  
pem\_management\_cert:  
subscription\_id:  
management\_endpoint:  
capacity:  
Small:  
Medium:  
Large:  
instance\_types:  
ExtraSmall:  
cpu: 1  
memory: 0.75  
Small:  
cpu: 1  
memory: 1.75  
Medium:  
cpu: 2  
memory: 3.5  
Large:  
cpu: 4  
memory: 7.0  
ExtraLarge:  
cpu: 8  
memory: 14.0  
A5:  
cpu: 2  
memory: 14.0  
A6:  
cpu: 4  
memory: 28.0  
A7:  
cpu: 8  
memory: 56.0  
A8:  
cpu: 8  
memory: 56.0  
A9:  
cpu: 16  
memory: 112.0  
A10:  
cpu: 8  
memory: 56.0  
A11:  
cpu: 16  
memory: 112.0  
Standard\_D1:  
cpu: 1  
memory: 3.5  
Standard\_D2:  
cpu: 2  
memory: 7.0  
Standard\_D3:  
cpu: 4  
memory: 14.0  
Standard\_D4:  
cpu: 8  
memory: 28.0  
Standard\_D11:  
cpu: 2  
memory: 14.0  
Standard\_D12:  
cpu: 4  
memory: 28.0  
Standard\_D13:  
cpu: 8  
memory: 56.0  
Standard\_D14:  
cpu: 16  
memory: 112.0  
Standard\_D1\_v2:  
cpu: 1  
memory: 3.5  
Standard\_D2\_v2:  
cpu: 2  
memory: 7.0  
Standard\_D3\_v2:  
cpu: 4  
memory: 14.0  
Standard\_D4\_v2:  
cpu: 8  
memory: 28.0  
Standard\_D5\_v2:  
cpu: 16  
memory: 56.0  
Standard\_D11\_v2:  
cpu: 2  
memory: 14.0  
Standard\_D12\_v2:  
cpu: 4  
memory: 28.0  
Standard\_D13\_v2:  
cpu: 8  
memory: 56.0  
Standard\_D14\_v2:  
cpu: 16  
memory: 112.0  
Standard\_D15\_v2:  
cpu: 20  
memory: 140.0

---

<div class="post-metadata">

### Author: ![tinova](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/tinova/32/25_2.png) [@tinova](https://forum.opennebula.io/u/tinova)
#### Post date: [February 13, 2017, 8:07pm UTC](https://forum.opennebula.io/t/azure-driver-error-creating-azure-host/3779/4 "2017-02-13T20:07:32Z")

</div>

Under which user are you running the “oned” process?

---

<div class="post-metadata">

### Author: ![Senthil\_Panchatchara](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/senthil_panchatchara/32/5051_2.png) [@Senthil\_Panchatchara](https://forum.opennebula.io/u/Senthil_Panchatchara)
#### Post date: [February 13, 2017, 8:35pm UTC](https://forum.opennebula.io/t/azure-driver-error-creating-azure-host/3779/5 "2017-02-13T20:35:28Z")

</div>

Tinova

All the process are running under one admin. I am using the virtual box trial appliance image.

Senthil

---

<div class="post-metadata">

### Author: ![tinova](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/tinova/32/25_2.png) [@tinova](https://forum.opennebula.io/u/tinova)
#### Post date: [February 14, 2017, 9:42am UTC](https://forum.opennebula.io/t/azure-driver-error-creating-azure-host/3779/6 "2017-02-14T09:42:05Z")

</div>

That may be the issue.

Is the “oneadmin” user able to read the /root/myCert.pem file?

---

<div class="post-metadata">

### Author: ![Senthil\_Panchatchara](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/senthil_panchatchara/32/5051_2.png) [@Senthil\_Panchatchara](https://forum.opennebula.io/u/Senthil_Panchatchara)
#### Post date: [February 15, 2017, 7:23pm UTC](https://forum.opennebula.io/t/azure-driver-error-creating-azure-host/3779/7 "2017-02-15T19:23:24Z")

</div>

Tinova,

I went ahead and recreated the VM and created the certificate again. The cluster host created still errors.

Can you provide me a sample Azure Template (full one including the context) that i could use?  
The one i have deployed throws the following error message.

Error deploying virtual machine: Error creating directory /var/lib/one/datastores/0/0 at east-us: ssh: Could not resolve hostname east-us: Name or service not known

---

<div class="post-metadata">

### Author: ![tinova](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/tinova/32/25_2.png) [@tinova](https://forum.opennebula.io/u/tinova)
#### Post date: [February 16, 2017, 10:28am UTC](https://forum.opennebula.io/t/azure-driver-error-creating-azure-host/3779/8 "2017-02-16T10:28:27Z")

</div>

Before moving on to the creation of an Azure Template (you can find a functional sample in the [documentation](http://docs.opennebula.org/5.2/advanced_components/cloud_bursting/azg.html#azure-specific-template-attributes), you need to correctly add a configured Azure host in OpenNebula, and achieve the “on” state on it.

Let’s go step by step, please answer to the following:

- Is the myCert.pem file readable by oneadmin?
- Can you share the output of "onehost show -x ", where hid is the id of the host with name “east-us”
