# Ceph datastore host parse error

**URL:** <https://forum.opennebula.io/t/ceph-datastore-host-parse-error/8937>\
**Category:** Operations\
**Created:** [October 29, 2020, 2:22pm UTC](https://forum.opennebula.io/t/ceph-datastore-host-parse-error/8937 "2020-10-29T14:22:20Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mosharaflink](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/mosharaflink/32/5953_2.png) [@mosharaflink](https://forum.opennebula.io/u/mosharaflink)\
**Post date:** [October 29, 2020, 2:22pm UTC](https://forum.opennebula.io/t/ceph-datastore-host-parse-error/8937/1 "2020-10-29T14:22:20Z")

</div>

Hi  
Recently we are facing an issue with ceph datastore in OpenNebula. In Ceph datastore, ceph-host section we previously added as "CEPH\_HOST = “mon1 ceph1 ceph2 ceph3 ceph6"” which works properly. But now a day whenever I am trying to deploy/migrate/ an vm to CEPH datastore generating an error of “unable to parse address in ‘mon1:6789;ceph1:6789;ceph2:6789;ceph3:6789;ceph6:6789’” though from system all address are resolved.

I have resolved this issue by replacing the hostname using IP and then all operations work properly. But why such happening??

---

<div class="post-metadata">

**Author:** ![Alexander\_Litvak](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/alexander_litvak/32/5935_2.png) [@Alexander\_Litvak](https://forum.opennebula.io/u/Alexander_Litvak)\
**Post date:** [November 1, 2020, 6:39pm UTC](https://forum.opennebula.io/t/ceph-datastore-host-parse-error/8937/2 "2020-11-01T18:39:52Z")

</div>

What is your Ceph version?

---

<div class="post-metadata">

**Author:** ![mosharaflink](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/mosharaflink/32/5953_2.png) [@mosharaflink](https://forum.opennebula.io/u/mosharaflink)\
**Post date:** [November 5, 2020, 4:09am UTC](https://forum.opennebula.io/t/ceph-datastore-host-parse-error/8937/3 "2020-11-05T04:09:09Z")

</div>

I am using ceph nautilus version and already integrated with the OpenNebula 5.8 version. Previously there is no issue with adding host but getting an error now.
