# Change deployment host

**URL:** <https://forum.opennebula.io/t/change-deployment-host/5495>\
**Category:** Product Support\
**Created:** [December 29, 2017, 1:42pm UTC](https://forum.opennebula.io/t/change-deployment-host/5495 "2017-12-29T13:42:12Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![oscar](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/oscar/32/5120_2.png) [@oscar](https://forum.opennebula.io/u/oscar)\
**Post date:** [December 29, 2017, 1:42pm UTC](https://forum.opennebula.io/t/change-deployment-host/5495/1 "2017-12-29T13:42:13Z")

</div>

Hi,

After a successful undeployment of a VM I have clicked the resume button in sunstone web interface.

Opennebula scheduler has chosen a new host that it is not properly working. I have powered off the host (sunstone has marked the powered-off host as ERROR what it is correct).

Now, I’d like to deploy my VM on another host but i’m not able to change the host

> USER TEMPLATE  
> ERROR=“Fri Dec 29 13:56:26 2017 : Error deploying virtual machine: Error creating directory /var/lib/one/datastores/100/27 at vdicnode03: ssh: connect to host vdicnode03 port 22: No route to host”  
> HYPERVISOR=“kvm”  
> INPUTS\_ORDER=“”  
> LOGO=“images/logos/windows8.png”  
> SCHED\_DS\_REQUIREMENTS=“ID="100"”  
> USER\_INPUTS=[  
> CPU=“O|fixed|| |1”,  
> MEMORY=“M|list||1024,2048,3072,4096|2048” ]
> 
> VIRTUAL MACHINE TEMPLATE  
> AUTOMATIC\_DS\_REQUIREMENTS=“"CLUSTERS/ID" @\> 0”  
> AUTOMATIC\_REQUIREMENTS=“(CLUSTER\_ID = 0) & !(PUBLIC\_CLOUD = YES)”  
> CONTEXT=[  
> DISK\_ID=“1”,  
> ETH0\_CONTEXT\_FORCE\_IPV4=“”,  
> ETH0\_DNS=“”,  
> ETH0\_GATEWAY=“”,  
> ETH0\_GATEWAY6=“”,  
> ETH0\_IP=“”,  
> ETH0\_IP6=“”,  
> ETH0\_IP6\_PREFIX\_LENGTH=“”,  
> ETH0\_IP6\_ULA=“”,  
> ETH0\_MAC=“02:00:2f:4e:9c:3e”,  
> ETH0\_MASK=“”,  
> ETH0\_MTU=“”,  
> ETH0\_NETWORK=“”,  
> ETH0\_SEARCH\_DOMAIN=“”,  
> ETH0\_VLAN\_ID=“3”,  
> ETH0\_VROUTER\_IP=“”,  
> ETH0\_VROUTER\_IP6=“”,  
> ETH0\_VROUTER\_MANAGEMENT=“”,  
> NETWORK=“YES”,  
> TARGET=“hda” ]  
> CPU=“1”  
> FEATURES=[  
> ACPI=“yes”,  
> APIC=“yes”,  
> GUEST\_AGENT=“yes”,  
> VIRTIO\_SCSI\_QUEUES=“4” ]  
> GRAPHICS=[  
> KEYMAP=“es”,  
> LISTEN=“0.0.0.0”,  
> PORT=“5927”,  
> TYPE=“SPICE” ]  
> INPUT=[  
> BUS=“usb”,  
> TYPE=“tablet” ]  
> MEMORY=“1024”  
> OS=[  
> ARCH=“x86\_64”,  
> BOOT=“”,  
> ROOT=“hd” ]  
> RAW=[  
> DATA=“SandyBridge”,  
> TYPE=“kvm” ]  
> TEMPLATE\_ID=“1”  
> VCPU=“2”  
> VMID=“27”  
> [root@vdicone01 100]#

All options in Sunstone are disabled but “Recover” that does not fix the problem as system always is trying to deploy the VM on a powered off host.

Is there any way to change the deployment host?

Thanks a lot in advance,

* * *

**Versions of the related components and OS (frontend, hypervisors, VMs):**  
Opennebula 5.4  
KVM

**Steps to reproduce:**  
Explained before

**Current results:**  
Explained before

**Expected results:**  
Be able to change the host where deploy the VM to.

---

<div class="post-metadata">

**Author:** ![marcindulak](https://avatars.discourse-cdn.com/v4/letter/m/a3d4f5/32.png) [@marcindulak](https://forum.opennebula.io/u/marcindulak)\
**Post date:** [December 31, 2017, 12:27pm UTC](https://forum.opennebula.io/t/change-deployment-host/5495/2 "2017-12-31T12:27:43Z")

</div>

You may try to use cli: `onevm deploy <vm_id> <host_id>` to force the specific host [https://docs.opennebula.org/doc/5.4/cli/onevm.1.html](https://docs.opennebula.org/doc/5.4/cli/onevm.1.html)  
Before this try to get the information about the state of the VM, using `onevm show <vm_id>`, as  
you may need to execute other `onevm` commands before being able to deploy again.
