# Error executing image transfer script after stopping VM

**URL:** <https://forum.opennebula.io/t/error-executing-image-transfer-script-after-stopping-vm/6188>\
**Category:** Product Support\
**Created:** [July 21, 2018, 9:09am UTC](https://forum.opennebula.io/t/error-executing-image-transfer-script-after-stopping-vm/6188 "2018-07-21T09:09:40Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![v3ng](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/v3ng/32/5634_2.png) [@v3ng](https://forum.opennebula.io/u/v3ng)\
**Post date:** [July 21, 2018, 9:09am UTC](https://forum.opennebula.io/t/error-executing-image-transfer-script-after-stopping-vm/6188/1 "2018-07-21T09:09:40Z")

</div>

Hi,

When stopping a VM, it fails with the message “Error executing image transfer script: Error copying disk directory to target host”. This only seems to happen when stopping VMs, deploying a new works without a problem

OpenNebula Version: OpenNebula 5.6.0  
OS: Debian 9

**Log of the VM:**

```
Sat Jul 21 11:00:56 2018 [Z0][VM][I]: New LCM state is SAVE_STOP
Sat Jul 21 11:00:57 2018 [Z0][VMM][I]: /var/tmp/one/vmm/kvm/save: line 58: warning: command substitution: ignored null byte in input
Sat Jul 21 11:00:57 2018 [Z0][VMM][I]: ExitCode: 0
Sat Jul 21 11:00:57 2018 [Z0][VMM][I]: Successfully execute virtualization driver operation: save.
Sat Jul 21 11:00:57 2018 [Z0][VMM][I]: ExitCode: 0
Sat Jul 21 11:00:57 2018 [Z0][VMM][I]: Successfully execute network driver operation: clean.
Sat Jul 21 11:00:57 2018 [Z0][VM][I]: New LCM state is EPILOG_STOP
Sat Jul 21 11:00:58 2018 [Z0][TM][I]: Command execution failed (exit code: 2): /var/lib/one/remotes/tm/ssh/mv localhost:/var/lib/one//datastores/0/51 virt.xxxx.de:/var/lib/one//datastores/0/51 51 0
Sat Jul 21 11:00:58 2018 [Z0][TM][I]: mv: Moving localhost:/var/lib/one/datastores/0/51 to virt.xxxxx.de:/var/lib/one/datastores/0/51
Sat Jul 21 11:00:58 2018 [Z0][TM][E]: mv: Command "set -e -o pipefail
Sat Jul 21 11:00:58 2018 [Z0][TM][I]: 
Sat Jul 21 11:00:58 2018 [Z0][TM][I]: tar -C /var/lib/one/datastores/0 --sparse -cf - 51 | ssh virt.xxxxx.de 'tar -C /var/lib/one/datastores/0 --sparse -xf -'
Sat Jul 21 11:00:58 2018 [Z0][TM][I]: rm -rf /var/lib/one/datastores/0/51" failed: tar: 51: Cannot stat: No such file or directory
Sat Jul 21 11:00:58 2018 [Z0][TM][I]: tar: Exiting with failure status due to previous errors
Sat Jul 21 11:00:58 2018 [Z0][TM][E]: Error copying disk directory to target host
Sat Jul 21 11:00:58 2018 [Z0][TM][E]: Error executing image transfer script: Error copying disk directory to target host
Sat Jul 21 11:00:58 2018 [Z0][VM][I]: New LCM state is EPILOG_STOP_FAILURE

```

**If I run the command which fails directly, I get the following output:**

```
/var/lib/one/remotes/tm/ssh/mv localhost:/var/lib/one//datastores/0/51 virt.xxxxx.de:/var/lib/one//datastores/0/51 51 0
INFO: mv: Moving localhost:/var/lib/one/datastores/0/51 to virt.xxxxx.de:/var/lib/one/datastores/0/51
ERROR: mv: Command "set -e -o pipefail

tar -C /var/lib/one/datastores/0 --sparse -cf - 51 | ssh virt.xxxxx.de 'tar -C /var/lib/one/datastores/0 --sparse -xf -'
rm -rf /var/lib/one/datastores/0/51" failed: tar: 51: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors
ERROR MESSAGE --8<------
Error copying disk directory to target host
ERROR MESSAGE ------>8--

```

Thanks!
