# Error executing image transfer script: Error copying one-sandbox

**URL:** https://forum.opennebula.io/t/error-executing-image-transfer-script-error-copying-one-sandbox/3098
**Category:** Product Support
**Created:** [October 7, 2016, 2:48pm UTC](https://forum.opennebula.io/t/error-executing-image-transfer-script-error-copying-one-sandbox/3098 "2016-10-07T14:48:29Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Dmitry1](https://avatars.discourse-cdn.com/v4/letter/d/f14d63/32.png) [@Dmitry1](https://forum.opennebula.io/u/Dmitry1)
#### Post date: [October 7, 2016, 2:48pm UTC](https://forum.opennebula.io/t/error-executing-image-transfer-script-error-copying-one-sandbox/3098/1 "2016-10-07T14:48:29Z")

</div>

Continue from thread:

> [@Cannot schedule VM, there is no suitable system ds](https://forum.opennebula.io/t/cannot-schedule-vm-there-is-no-suitable-system-ds/2973):
>
> Hello, I can’t understand why datastore cannot be applied for VM, VM is in pending state: Persistent or not, doesn’t matter. Resources should be enough. Thu Sep 22 18:18:33 2016 [Z0][VM][D]: Found 2 pending/rescheduling VMs. Thu Sep 22 18:18:33 2016 [Z0][HOST][D]: Discovered 2 enabled hosts. Thu Sep 22 18:18:33 2016 [Z0][SCHED][D]: Match-making results for VM 15: Cannot schedule VM, there is no suitable system ds. Thu Sep 22 18:18:33 2016 [Z0][SCHED][D]: Match-making results for VM 17: C…

Now for some images I can’t create VM because it rejects to copy files.

Fri Oct 7 14:11:16 2016 : Error executing image transfer script: Error copying one-sandbox:/var/lib/one//datastores/109/ec6eb8e2c187e1053b2f332ce735da63 to 10.110.20.151:/var/lib/one//datastores/110/25/disk.0

Some other VMs can be created. Can’t understand why=(

---

<div class="post-metadata">

### Author: ![atodorov\_storpool](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/atodorov_storpool/32/5327_2.png) [@atodorov\_storpool](https://forum.opennebula.io/u/atodorov_storpool)
#### Post date: [October 7, 2016, 3:15pm UTC](https://forum.opennebula.io/t/error-executing-image-transfer-script-error-copying-one-sandbox/3098/2 "2016-10-07T15:15:44Z")

</div>

Hi Dmitry1,

Can you provide few more lines after this error message? it is common to have clues what is wrong.  
Also, attaching the output of the following commands (run them on the front-end a.k.a. “sunstone”) could help in resolving the issue:

```
onehost list --xml
onedatastore list --xml
oneimage list --xml
onetemplate list --xml

```

And let us know what is the template of the failing VM, ( with ID 25)

Common cases are SSH permissions, file permissions, etc. But is is hard to figure out from only one line of the logfile

Kind Regards,  
Anton Todorov
