# Error message: 'Missing datastore id'

**URL:** <https://forum.opennebula.io/t/error-message-missing-datastore-id/7199>\
**Category:** Product Support\
**Created:** [May 7, 2019, 11:07am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199 "2019-05-07T11:07:14Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![wm1](https://avatars.discourse-cdn.com/v4/letter/w/e274bd/32.png) [@wm1](https://forum.opennebula.io/u/wm1)\
**Post date:** [May 7, 2019, 11:07am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/1 "2019-05-07T11:07:14Z")

</div>

Following your installation instructions i installed OpenNebula in my Virtualbox 5.2.2 for testing it on Debian 9.9 netinst. Front-End and 2 nodes installed fine, no errors until [verifying installation](https://docs.opennebula.org/5.8/deployment/node_installation/verify.html#verify-installation). When i press the Download-Button for downloading tty kvm from marketplace, an error pops up: ‘Missing datastore id’

What did i do wrong in my installation?

---

<div class="post-metadata">

**Author:** ![ahuertas](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/ahuertas/32/7487_2.png) [@ahuertas](https://forum.opennebula.io/u/ahuertas)\
**Post date:** [May 7, 2019, 12:53pm UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/2 "2019-05-07T12:53:12Z")

</div>

Hello @wm1

Could you please send me the output of `onedatastore list -x`?

---

<div class="post-metadata">

**Author:** ![wm1](https://avatars.discourse-cdn.com/v4/letter/w/e274bd/32.png) [@wm1](https://forum.opennebula.io/u/wm1)\
**Post date:** [May 7, 2019, 2:32pm UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/3 "2019-05-07T14:32:15Z")

</div>

oneadmin@vonfe:~$ onedatastore list -x  
\<DATASTORE\_POOL\>  
  
2  
0  
0  
oneadmin  
oneadmin  
files  
  
\<OWNER\_U\>1\</OWNER\_U\>  
\<OWNER\_M\>1\</OWNER\_M\>  
\<OWNER\_A\>0\</OWNER\_A\>  
\<GROUP\_U\>1\</GROUP\_U\>  
\<GROUP\_M\>0\</GROUP\_M\>  
\<GROUP\_A\>0\</GROUP\_A\>  
\<OTHER\_U\>0\</OTHER\_U\>  
\<OTHER\_M\>0\</OTHER\_M\>  
\<OTHER\_A\>0\</OTHER\_A\>  
  
\<DS\_MAD\>\</DS\_MAD\>  
\<TM\_MAD\>\</TM\_MAD\>  
\<BASE\_PATH\>\</BASE\_PATH\>  
2  
\<DISK\_TYPE\>0\</DISK\_TYPE\>  
0  
  
0  
  
\<TOTAL\_MB\>14047\</TOTAL\_MB\>  
\<FREE\_MB\>11579\</FREE\_MB\>  
\<USED\_MB\>1735\</USED\_MB\>  
  
  
\<ALLOW\_ORPHANS\>\</ALLOW\_ORPHANS\>  
\<CLONE\_TARGET\>\</CLONE\_TARGET\>  
\<DS\_MAD\>\</DS\_MAD\>  
\<LN\_TARGET\>\</LN\_TARGET\>  
\<RESTRICTED\_DIRS\>\</RESTRICTED\_DIRS\>  
\<SAFE\_DIRS\>\</SAFE\_DIRS\>  
\<TM\_MAD\>\</TM\_MAD\>  
  
  
  
  
1  
0  
0  
oneadmin  
oneadmin  
default  
  
\<OWNER\_U\>1\</OWNER\_U\>  
\<OWNER\_M\>1\</OWNER\_M\>  
\<OWNER\_A\>0\</OWNER\_A\>  
\<GROUP\_U\>1\</GROUP\_U\>  
\<GROUP\_M\>0\</GROUP\_M\>  
\<GROUP\_A\>0\</GROUP\_A\>  
\<OTHER\_U\>0\</OTHER\_U\>  
\<OTHER\_M\>0\</OTHER\_M\>  
\<OTHER\_A\>0\</OTHER\_A\>  
  
\<DS\_MAD\>\</DS\_MAD\>  
\<TM\_MAD\>\</TM\_MAD\>  
\<BASE\_PATH\>\</BASE\_PATH\>  
0  
\<DISK\_TYPE\>0\</DISK\_TYPE\>  
0  
  
0  
  
\<TOTAL\_MB\>14047\</TOTAL\_MB\>  
\<FREE\_MB\>11579\</FREE\_MB\>  
\<USED\_MB\>1735\</USED\_MB\>  
  
  
\<ALLOW\_ORPHANS\>\</ALLOW\_ORPHANS\>  
\<CLONE\_TARGET\>\</CLONE\_TARGET\>  
\<DISK\_TYPE\>\</DISK\_TYPE\>  
\<DS\_MAD\>\</DS\_MAD\>  
\<LN\_TARGET\>\</LN\_TARGET\>  
\<RESTRICTED\_DIRS\>\</RESTRICTED\_DIRS\>  
\<SAFE\_DIRS\>\</SAFE\_DIRS\>  
\<TM\_MAD\>\</TM\_MAD\>  
  
  
  
  
0  
0  
0  
oneadmin  
oneadmin  
system  
  
\<OWNER\_U\>1\</OWNER\_U\>  
\<OWNER\_M\>1\</OWNER\_M\>  
\<OWNER\_A\>0\</OWNER\_A\>  
\<GROUP\_U\>1\</GROUP\_U\>  
\<GROUP\_M\>0\</GROUP\_M\>  
\<GROUP\_A\>0\</GROUP\_A\>  
\<OTHER\_U\>0\</OTHER\_U\>  
\<OTHER\_M\>0\</OTHER\_M\>  
\<OTHER\_A\>0\</OTHER\_A\>  
  
\<DS\_MAD\>\</DS\_MAD\>  
\<TM\_MAD\>\</TM\_MAD\>  
\<BASE\_PATH\>\</BASE\_PATH\>  
1  
\<DISK\_TYPE\>0\</DISK\_TYPE\>  
0  
  
0  
  
\<TOTAL\_MB\>0\</TOTAL\_MB\>  
\<FREE\_MB\>0\</FREE\_MB\>  
\<USED\_MB\>0\</USED\_MB\>  
  
  
\<ALLOW\_ORPHANS\>\</ALLOW\_ORPHANS\>  
\<DISK\_TYPE\>\</DISK\_TYPE\>  
\<DS\_MIGRATE\>\</DS\_MIGRATE\>  
\<RESTRICTED\_DIRS\>\</RESTRICTED\_DIRS\>  
\<SAFE\_DIRS\>\</SAFE\_DIRS\>  
  
\<TM\_MAD\>\</TM\_MAD\>  
  
  
  
\</DATASTORE\_POOL\>

---

<div class="post-metadata">

**Author:** ![wm1](https://avatars.discourse-cdn.com/v4/letter/w/e274bd/32.png) [@wm1](https://forum.opennebula.io/u/wm1)\
**Post date:** [May 8, 2019, 7:42am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/4 "2019-05-08T07:42:24Z")

</div>

Hello Alejandro,

thanks for your help. Here your requested info:

oneadmin@vonfe:~$ onedatastore list -x  
\<DATASTORE\_POOL\>  
  
2  
0  
0  
oneadmin  
oneadmin  
files  
  
\<OWNER\_U\>1\</OWNER\_U\>  
\<OWNER\_M\>1\</OWNER\_M\>  
\<OWNER\_A\>0\</OWNER\_A\>  
\<GROUP\_U\>1\</GROUP\_U\>  
\<GROUP\_M\>0\</GROUP\_M\>  
\<GROUP\_A\>0\</GROUP\_A\>  
\<OTHER\_U\>0\</OTHER\_U\>  
\<OTHER\_M\>0\</OTHER\_M\>  
\<OTHER\_A\>0\</OTHER\_A\>  
  
\<DS\_MAD\>\</DS\_MAD\>  
\<TM\_MAD\>\</TM\_MAD\>

\<BASE\_PATH\>\</BASE\_PATH\>  
2  
\<DISK\_TYPE\>0\</DISK\_TYPE\>  
0  
  
0  
  
\<TOTAL\_MB\>14047\</TOTAL\_MB\>  
\<FREE\_MB\>11579\</FREE\_MB\>  
\<USED\_MB\>1735\</USED\_MB\>

\<ALLOW\_ORPHANS\>\</ALLOW\_ORPHANS\>

\<CLONE\_TARGET\>\</CLONE\_TARGET\>  
\<DS\_MAD\>\</DS\_MAD\>  
\<LN\_TARGET\>\</LN\_TARGET\>

\<RESTRICTED\_DIRS\>\</RESTRICTED\_DIRS\>  
\<SAFE\_DIRS\>\</SAFE\_DIRS\>  
\<TM\_MAD\>\</TM\_MAD\>  
  
  
  
  
1  
0  
0  
oneadmin  
oneadmin  
default  
  
\<OWNER\_U\>1\</OWNER\_U\>  
\<OWNER\_M\>1\</OWNER\_M\>  
\<OWNER\_A\>0\</OWNER\_A\>  
\<GROUP\_U\>1\</GROUP\_U\>  
\<GROUP\_M\>0\</GROUP\_M\>  
\<GROUP\_A\>0\</GROUP\_A\>  
\<OTHER\_U\>0\</OTHER\_U\>  
\<OTHER\_M\>0\</OTHER\_M\>  
\<OTHER\_A\>0\</OTHER\_A\>  
  
\<DS\_MAD\>\</DS\_MAD\>  
\<TM\_MAD\>\</TM\_MAD\>

\<BASE\_PATH\>\</BASE\_PATH\>  
0  
\<DISK\_TYPE\>0\</DISK\_TYPE\>  
0  
  
0  
  
\<TOTAL\_MB\>14047\</TOTAL\_MB\>  
\<FREE\_MB\>11579\</FREE\_MB\>  
\<USED\_MB\>1735\</USED\_MB\>

\<ALLOW\_ORPHANS\>\</ALLOW\_ORPHANS\>

\<CLONE\_TARGET\>\</CLONE\_TARGET\>  
\<DISK\_TYPE\>\</DISK\_TYPE\>  
\<DS\_MAD\>\</DS\_MAD\>  
\<LN\_TARGET\>\</LN\_TARGET\>

\<RESTRICTED\_DIRS\>\</RESTRICTED\_DIRS\>  
\<SAFE\_DIRS\>\</SAFE\_DIRS\>  
\<TM\_MAD\>\</TM\_MAD\>  
  
  
  
  
0  
0  
0  
oneadmin  
oneadmin  
system  
  
\<OWNER\_U\>1\</OWNER\_U\>  
\<OWNER\_M\>1\</OWNER\_M\>  
\<OWNER\_A\>0\</OWNER\_A\>  
\<GROUP\_U\>1\</GROUP\_U\>  
\<GROUP\_M\>0\</GROUP\_M\>  
\<GROUP\_A\>0\</GROUP\_A\>  
\<OTHER\_U\>0\</OTHER\_U\>  
\<OTHER\_M\>0\</OTHER\_M\>  
\<OTHER\_A\>0\</OTHER\_A\>  
  
\<DS\_MAD\>\</DS\_MAD\>  
\<TM\_MAD\>\</TM\_MAD\>

\<BASE\_PATH\>\</BASE\_PATH\>  
1  
\<DISK\_TYPE\>0\</DISK\_TYPE\>  
0  
  
0  
  
\<TOTAL\_MB\>0\</TOTAL\_MB\>  
\<FREE\_MB\>0\</FREE\_MB\>  
\<USED\_MB\>0\</USED\_MB\>

\<ALLOW\_ORPHANS\>\</ALLOW\_ORPHANS\>  
\<DISK\_TYPE\>\</DISK\_TYPE\>  
\<DS\_MIGRATE\>\</DS\_MIGRATE\>

\<RESTRICTED\_DIRS\>\</RESTRICTED\_DIRS\>  
\<SAFE\_DIRS\>\</SAFE\_DIRS\>  
  
\<TM\_MAD\>\</TM\_MAD\>  
  
  
  
\</DATASTORE\_POOL\>  
oneadmin@vonfe:~$

Best regards

---

<div class="post-metadata">

**Author:** ![ahuertas](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/ahuertas/32/7487_2.png) [@ahuertas](https://forum.opennebula.io/u/ahuertas)\
**Post date:** [May 8, 2019, 7:43am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/5 "2019-05-08T07:43:17Z")

</div>

It seems that the datastores are wrong configured, can you please create a new system and image datastore? Then try again.

---

<div class="post-metadata">

**Author:** ![wm1](https://avatars.discourse-cdn.com/v4/letter/w/e274bd/32.png) [@wm1](https://forum.opennebula.io/u/wm1)\
**Post date:** [May 8, 2019, 8:00am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/6 "2019-05-08T08:00:05Z")

</div>

I deleted Datastore id 0 and 1 and create new ones, 100 and 101. Same error.

---

<div class="post-metadata">

**Author:** ![ahuertas](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/ahuertas/32/7487_2.png) [@ahuertas](https://forum.opennebula.io/u/ahuertas)\
**Post date:** [May 8, 2019, 8:08am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/7 "2019-05-08T08:08:25Z")

</div>

Send me again the list please.

---

<div class="post-metadata">

**Author:** ![wm1](https://avatars.discourse-cdn.com/v4/letter/w/e274bd/32.png) [@wm1](https://forum.opennebula.io/u/wm1)\
**Post date:** [May 8, 2019, 8:13am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/8 "2019-05-08T08:13:00Z")

</div>

oneadmin@vonfe:~$ onedatastore list -x  
\<DATASTORE\_POOL\>  
  
101  
0  
0  
oneadmin  
oneadmin  
image  
  
\<OWNER\_U\>1\</OWNER\_U\>  
\<OWNER\_M\>1\</OWNER\_M\>  
\<OWNER\_A\>0\</OWNER\_A\>  
\<GROUP\_U\>1\</GROUP\_U\>  
\<GROUP\_M\>0\</GROUP\_M\>  
\<GROUP\_A\>0\</GROUP\_A\>  
\<OTHER\_U\>0\</OTHER\_U\>  
\<OTHER\_M\>0\</OTHER\_M\>  
\<OTHER\_A\>0\</OTHER\_A\>  
  
\<DS\_MAD\>\</DS\_MAD\>  
\<TM\_MAD\>\</TM\_MAD\>

\<BASE\_PATH\>\</BASE\_PATH\>  
0  
\<DISK\_TYPE\>0\</DISK\_TYPE\>  
0  
  
0  
  
\<TOTAL\_MB\>14047\</TOTAL\_MB\>  
\<FREE\_MB\>11579\</FREE\_MB\>  
\<USED\_MB\>1735\</USED\_MB\>

\<ALLOW\_ORPHANS\>\</ALLOW\_ORPHANS\>

\<CLONE\_TARGET\>\</CLONE\_TARGET\>

\<CLONE\_TARGET\_SSH\>\</CLONE\_TARGET\_SSH\>  
\<DISK\_TYPE\>\</DISK\_TYPE\>

\<DISK\_TYPE\_SSH\>\</DISK\_TYPE\_SSH\>  
\<DS\_MAD\>\</DS\_MAD\>  
\<LN\_TARGET\>\</LN\_TARGET\>

\<LN\_TARGET\_SSH\>\</LN\_TARGET\_SSH\>

\<RESTRICTED\_DIRS\>\</RESTRICTED\_DIRS\>  
\<SAFE\_DIRS\>\</SAFE\_DIRS\>  
\<TM\_MAD\>\</TM\_MAD\>

\<TM\_MAD\_SYSTEM\>\</TM\_MAD\_SYSTEM\>  
  
  
  
  
100  
0  
0  
oneadmin  
oneadmin  
default  
  
\<OWNER\_U\>1\</OWNER\_U\>  
\<OWNER\_M\>1\</OWNER\_M\>  
\<OWNER\_A\>0\</OWNER\_A\>  
\<GROUP\_U\>1\</GROUP\_U\>  
\<GROUP\_M\>0\</GROUP\_M\>  
\<GROUP\_A\>0\</GROUP\_A\>  
\<OTHER\_U\>0\</OTHER\_U\>  
\<OTHER\_M\>0\</OTHER\_M\>  
\<OTHER\_A\>0\</OTHER\_A\>  
  
\<DS\_MAD\>\</DS\_MAD\>  
\<TM\_MAD\>\</TM\_MAD\>

\<BASE\_PATH\>\</BASE\_PATH\>  
1  
\<DISK\_TYPE\>0\</DISK\_TYPE\>  
0  
  
0  
  
\<TOTAL\_MB\>14047\</TOTAL\_MB\>  
\<FREE\_MB\>11579\</FREE\_MB\>  
\<USED\_MB\>1735\</USED\_MB\>

\<ALLOW\_ORPHANS\>\</ALLOW\_ORPHANS\>  
\<DISK\_TYPE\>\</DISK\_TYPE\>  
\<DS\_MIGRATE\>\</DS\_MIGRATE\>

\<RESTRICTED\_DIRS\>\</RESTRICTED\_DIRS\>  
\<SAFE\_DIRS\>\</SAFE\_DIRS\>  
  
\<TM\_MAD\>\</TM\_MAD\>  
  
  
  
  
2  
0  
0  
oneadmin  
oneadmin  
files  
  
\<OWNER\_U\>1\</OWNER\_U\>  
\<OWNER\_M\>1\</OWNER\_M\>  
\<OWNER\_A\>0\</OWNER\_A\>  
\<GROUP\_U\>1\</GROUP\_U\>  
\<GROUP\_M\>0\</GROUP\_M\>  
\<GROUP\_A\>0\</GROUP\_A\>  
\<OTHER\_U\>0\</OTHER\_U\>  
\<OTHER\_M\>0\</OTHER\_M\>  
\<OTHER\_A\>0\</OTHER\_A\>  
  
\<DS\_MAD\>\</DS\_MAD\>  
\<TM\_MAD\>\</TM\_MAD\>

\<BASE\_PATH\>\</BASE\_PATH\>  
2  
\<DISK\_TYPE\>0\</DISK\_TYPE\>  
0  
  
0  
  
\<TOTAL\_MB\>14047\</TOTAL\_MB\>  
\<FREE\_MB\>11579\</FREE\_MB\>  
\<USED\_MB\>1735\</USED\_MB\>

\<ALLOW\_ORPHANS\>\</ALLOW\_ORPHANS\>

\<CLONE\_TARGET\>\</CLONE\_TARGET\>  
\<DS\_MAD\>\</DS\_MAD\>  
\<LN\_TARGET\>\</LN\_TARGET\>

\<RESTRICTED\_DIRS\>\</RESTRICTED\_DIRS\>  
\<SAFE\_DIRS\>\</SAFE\_DIRS\>  
\<TM\_MAD\>\</TM\_MAD\>  
  
  
  
\</DATASTORE\_POOL\>  
oneadmin@vonfe:~$

 ![](https://canada1.discourse-cdn.com/flex031/uploads/opennebula/original/2X/0/08122f08a25a2546d8d13fa7a25ad35fa25f4d5f.jpeg)

---

<div class="post-metadata">

**Author:** ![ahuertas](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/ahuertas/32/7487_2.png) [@ahuertas](https://forum.opennebula.io/u/ahuertas)\
**Post date:** [May 8, 2019, 8:15am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/9 "2019-05-08T08:15:17Z")

</div>

The problem is that the datastores table is not showing to you.

Try to update the tm\_mad and ds\_mad of each datastore.

---

<div class="post-metadata">

**Author:** ![wm1](https://avatars.discourse-cdn.com/v4/letter/w/e274bd/32.png) [@wm1](https://forum.opennebula.io/u/wm1)\
**Post date:** [May 8, 2019, 8:17am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/10 "2019-05-08T08:17:06Z")

</div>

How to do that? I’m new to OpenN.

---

<div class="post-metadata">

**Author:** ![ahuertas](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/ahuertas/32/7487_2.png) [@ahuertas](https://forum.opennebula.io/u/ahuertas)\
**Post date:** [May 8, 2019, 8:19am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/11 "2019-05-08T08:19:09Z")

</div>

`onedatastore update 100` and change the value then do the same for 101.

There are several types of ds\_mad and tm\_mad depending on the storage you are using, [here](http://docs.opennebula.org/5.8/deployment/open_cloud_storage_setup/overview.html) you can find more information.

---

<div class="post-metadata">

**Author:** ![wm1](https://avatars.discourse-cdn.com/v4/letter/w/e274bd/32.png) [@wm1](https://forum.opennebula.io/u/wm1)\
**Post date:** [May 8, 2019, 8:42am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/12 "2019-05-08T08:42:25Z")

</div>

When i run this `'``onedatastore update 100'`  
command at the front end, it opens up vi. I use joe as editor, not  
vi.

```
  Maybe the problem is while running Front-End and nodes in Oracle

```

Virtualbox as virtual machines.

```
  I think i stop here and not go on wasting my time from changing

```

my proxmox cluster to Open Nebula. Maybe i try again later when ON  
is more stable and the demo works in Virtualbox.

Thank you very much. Enjoy your day.

---

<div class="post-metadata">

**Author:** ![michaudg](https://avatars.discourse-cdn.com/v4/letter/m/e9a140/32.png) [@michaudg](https://forum.opennebula.io/u/michaudg)\
**Post date:** [May 12, 2019, 7:02pm UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/13 "2019-05-12T19:02:13Z")

</div>

Same problem here using _minione_-lxd installation method on Ubuntu 18.04. I tried to delete the default datastore and recreate a new one but it didn’t show in the apps download page.

The `onemarketapp export` command works great. The problem seems to be only with Sunstone.

---

<div class="post-metadata">

**Author:** ![kanshi](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/kanshi/32/6058_2.png) [@kanshi](https://forum.opennebula.io/u/kanshi)\
**Post date:** [May 13, 2019, 1:23pm UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/14 "2019-05-13T13:23:39Z")

</div>

I just bumped into this too… and found a somewhat working workaround.

When you select an image and click the button (on the list of all images) then the “Download App to OpenNebula” doesn’t show the table with datastores to choose to store the image.

When I open the app image details and click the button to Download App to OpenNebula I also sometimes am missing the table, but hitting refresh and going there again (repeat if necessary) fixes the issue.

---

<div class="post-metadata">

**Author:** ![ahuertas](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/ahuertas/32/7487_2.png) [@ahuertas](https://forum.opennebula.io/u/ahuertas)\
**Post date:** [May 13, 2019, 1:26pm UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/15 "2019-05-13T13:26:41Z")

</div>

It seems to be a Sunstone bug, we will take a look at it, to solve it, thanks for your feedback!

---

<div class="post-metadata">

**Author:** ![wm1](https://avatars.discourse-cdn.com/v4/letter/w/e274bd/32.png) [@wm1](https://forum.opennebula.io/u/wm1)\
**Post date:** [May 13, 2019, 2:33pm UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/16 "2019-05-13T14:33:13Z")

</div>

jep, i just find that out also. thanks

---

<div class="post-metadata">

**Author:** ![wm1](https://avatars.discourse-cdn.com/v4/letter/w/e274bd/32.png) [@wm1](https://forum.opennebula.io/u/wm1)\
**Post date:** [May 13, 2019, 2:34pm UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/17 "2019-05-13T14:34:00Z")

</div>

yw, thanks for jour help.

---

<div class="post-metadata">

**Author:** ![jlobo](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/jlobo/32/5955_2.png) [@jlobo](https://forum.opennebula.io/u/jlobo)\
**Post date:** [May 16, 2019, 8:48am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/18 "2019-05-16T08:48:51Z")

</div>

[export.js](https://canada1.discourse-cdn.com/flex031/uploads/opennebula/original/2X/8/8d3c2839df5e1dd580f7be69350854fa3e67a00e.js) (4.9 KB)

Try replacing this file in “repo” /one/src/sunstone/public/app/tabs/marketplaceapps-tab/form-panels/export.js, and rebuild the sunstone code. to have it go to the browser and with the open devtool you can send me a screenshot

---

<div class="post-metadata">

**Author:** ![wm1](https://avatars.discourse-cdn.com/v4/letter/w/e274bd/32.png) [@wm1](https://forum.opennebula.io/u/wm1)\
**Post date:** [May 17, 2019, 8:52am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/19 "2019-05-17T08:52:27Z")

</div>

Thanks for your help, but i have no development setup. Just tried  
out your demo install.

---

<div class="post-metadata">

**Author:** ![superxor](https://avatars.discourse-cdn.com/v4/letter/s/ee59a6/32.png) [@superxor](https://forum.opennebula.io/u/superxor)\
**Post date:** [August 11, 2019, 10:25am UTC](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199/20 "2019-08-11T10:25:35Z")

</div>

this bug is still open in 5.8.1  
created a fresh new cluster, same error  
workaround with hitting refresh works

[Next page](https://forum.opennebula.io/t/error-message-missing-datastore-id/7199.md?page=2)
