# Error starting Sunstone

**URL:** <https://forum.opennebula.io/t/error-starting-sunstone/3625>\
**Category:** Product Support\
**Created:** [January 23, 2017, 7:42pm UTC](https://forum.opennebula.io/t/error-starting-sunstone/3625 "2017-01-23T19:42:30Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![oscar](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/oscar/32/5120_2.png) [@oscar](https://forum.opennebula.io/u/oscar)\
**Post date:** [January 23, 2017, 7:42pm UTC](https://forum.opennebula.io/t/error-starting-sunstone/3625/1 "2017-01-23T19:42:30Z")

</div>

Hi,

I have installed a saparate sunstone server 5.1 but It does not start:

```
service opennebula-sunstone start
Redirecting to /bin/systemctl start opennebula-sunstone.service
Job for opennebula-sunstone.service failed because the control process exited with error code. See "systemctl status opennebula-sunstone.service" and "journalctl -xe" for details.

[root@vdicsunstone01 one]# systemctl status opennebula-sunstone.service
● opennebula-sunstone.service - OpenNebula Web UI Server
   Loaded: loaded (/usr/lib/systemd/system/opennebula-sunstone.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2017-01-23 20:40:12 CET; 17s ago
  Process: 11966 ExecStartPre=/usr/sbin/logrotate -s /tmp/logrotate.state -f /etc/logrotate.d/opennebula (code=exited, status=1/FAILURE)

Jan 23 20:40:12 vdicsunstone01 systemd[1]: Starting OpenNebula Web UI Server...
Jan 23 20:40:12 vdicsunstone01 systemd[1]: opennebula-sunstone.service: control process exited, code=exited status=1
Jan 23 20:40:12 vdicsunstone01 systemd[1]: Failed to start OpenNebula Web UI Server.
Jan 23 20:40:12 vdicsunstone01 systemd[1]: Unit opennebula-sunstone.service entered failed state.
Jan 23 20:40:12 vdicsunstone01 systemd[1]: opennebula-sunstone.service failed.
[root@vdicsunstone01 one]#

```

* * *

```
Jan 23 20:25:27 vdicsunstone01 dhclient[2110]: DHCPREQUEST on eth0 to 192.168.50.1 port 67 (xid=0xe5cb047)
Jan 23 20:25:27 vdicsunstone01 dhclient[2110]: DHCPACK from 192.168.50.1 (xid=0xe5cb047)
Jan 23 20:25:27 vdicsunstone01 NetworkManager[610]: <info> [1485199527.2707] dhcp4 (eth0): address 192.168.50.7
Jan 23 20:25:27 vdicsunstone01 NetworkManager[610]: <info> [1485199527.2708] dhcp4 (eth0): plen 24 (255.255.255.0)
Jan 23 20:25:27 vdicsunstone01 NetworkManager[610]: <info> [1485199527.2708] dhcp4 (eth0): gateway 192.168.50.1
Jan 23 20:25:27 vdicsunstone01 NetworkManager[610]: <info> [1485199527.2709] dhcp4 (eth0): server identifier 192.168.50.1
Jan 23 20:25:27 vdicsunstone01 NetworkManager[610]: <info> [1485199527.2709] dhcp4 (eth0): lease time 3600
Jan 23 20:25:27 vdicsunstone01 NetworkManager[610]: <info> [1485199527.2709] dhcp4 (eth0): hostname 'vdicsunstone01'
Jan 23 20:25:27 vdicsunstone01 NetworkManager[610]: <info> [1485199527.2709] dhcp4 (eth0): nameserver '192.168.50.1'
Jan 23 20:25:27 vdicsunstone01 NetworkManager[610]: <info> [1485199527.2709] dhcp4 (eth0): domain name 'vdicube.com'
Jan 23 20:25:27 vdicsunstone01 NetworkManager[610]: <info> [1485199527.2709] dhcp4 (eth0): state changed bound -> bound
Jan 23 20:25:27 vdicsunstone01 dbus[606]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
Jan 23 20:25:27 vdicsunstone01 systemd[1]: Cannot add dependency job for unit microcode.service, ignoring: Unit is not loaded properly: Invalid argument.
Jan 23 20:25:27 vdicsunstone01 dbus-daemon[606]: dbus[606]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
Jan 23 20:25:27 vdicsunstone01 systemd[1]: Starting Network Manager Script Dispatcher Service...
-- Subject: Unit NetworkManager-dispatcher.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit NetworkManager-dispatcher.service has begun starting up.
Jan 23 20:25:27 vdicsunstone01 dhclient[2110]: bound to 192.168.50.7 -- renewal in 1430 seconds.
Jan 23 20:25:27 vdicsunstone01 dbus[606]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Jan 23 20:25:27 vdicsunstone01 dbus-daemon[606]: dbus[606]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Jan 23 20:25:27 vdicsunstone01 systemd[1]: Started Network Manager Script Dispatcher Service.
-- Subject: Unit NetworkManager-dispatcher.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit NetworkManager-dispatcher.service has finished starting up.
--
-- The start-up result is done.
Jan 23 20:25:27 vdicsunstone01 nm-dispatcher[11885]: req:1 'dhcp4-change' [eth0]: new request (2 scripts)
Jan 23 20:25:27 vdicsunstone01 nm-dispatcher[11885]: req:1 'dhcp4-change' [eth0]: start running ordered scripts...
Jan 23 20:28:17 vdicsunstone01 polkitd[612]: Registered Authentication Agent for unix-process:11905:357001 (system bus name :1.37 [/usr/bin/pkttyagent --notify-fd 5 --fallback], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Jan 23 20:28:17 vdicsunstone01 systemd[1]: Cannot add dependency job for unit microcode.service, ignoring: Unit is not loaded properly: Invalid argument.
Jan 23 20:28:17 vdicsunstone01 systemd[1]: Starting OpenNebula Web UI Server...
-- Subject: Unit opennebula-sunstone.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit opennebula-sunstone.service has begun starting up.
Jan 23 20:28:17 vdicsunstone01 logrotate[11922]: error: cannot stat /etc/logrotate.d/opennebula: No such file or directory
Jan 23 20:28:17 vdicsunstone01 systemd[1]: opennebula-sunstone.service: control process exited, code=exited status=1
Jan 23 20:28:17 vdicsunstone01 systemd[1]: Failed to start OpenNebula Web UI Server.
-- Subject: Unit opennebula-sunstone.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit opennebula-sunstone.service has failed.
--
-- The result is failed.
Jan 23 20:28:17 vdicsunstone01 systemd[1]: Unit opennebula-sunstone.service entered failed state.
Jan 23 20:28:17 vdicsunstone01 systemd[1]: opennebula-sunstone.service failed.
Jan 23 20:28:17 vdicsunstone01 polkitd[612]: Unregistered Authentication Agent for unix-process:11905:357001 (system bus name :1.37, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)

```

Any help will be welcome,

Thanks a lot.

---

<div class="post-metadata">

**Author:** ![atodorov\_storpool](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/atodorov_storpool/32/5327_2.png) [@atodorov\_storpool](https://forum.opennebula.io/u/atodorov_storpool)\
**Post date:** [January 24, 2017, 9:10am UTC](https://forum.opennebula.io/t/error-starting-sunstone/3625/2 "2017-01-24T09:10:45Z")

</div>

Hi oscar,

> [@oscar](#):
>
> Jan 23 20:28:17 vdicsunstone01 logrotate[11922]: error: cannot stat /etc/logrotate.d/opennebula: No such file or directory

I think it is packaging issue. the `/etc/logrotate.d/opennebula` file is provided by `opennebula-server` package

```
# yum whatprovides /etc/logrotate.d/opennebula
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.telepoint.bg
 * epel: mirrors.uni-ruse.bg
 * extras: mirror.telepoint.bg
 * updates: mirror.telepoint.bg
opennebula-server-5.2.1-1.x86_64 : Provides the OpenNebula servers
Repo : @opennebula
Matched from:
Filename : /etc/logrotate.d/opennebula

```

but as it is used by more than one service package I believe it should be placed in `opennebula-common`.

The simple solution is to get the `/etc/logrotate.d/opennebula` file from a host where `opennebula-server` is installed or extract it from the opennebula-server’s RPM.

@OpenNebula devs - I can’t find the `spec` file in the repo to suggest a patch :(.

Kind Regards,  
Anton Todorov

---

<div class="post-metadata">

**Author:** ![KevinMMontalvo](https://avatars.discourse-cdn.com/v4/letter/k/2bfe46/32.png) [@KevinMMontalvo](https://forum.opennebula.io/u/KevinMMontalvo)\
**Post date:** [December 8, 2018, 7:09pm UTC](https://forum.opennebula.io/t/error-starting-sunstone/3625/3 "2018-12-08T19:09:44Z")

</div>

Hi

I resolve the problem with **sudo gem install xmlrpc**

Regards  
Kevin M.  
Ecuador
