# Error while Undeploy

**URL:** <https://forum.opennebula.io/t/error-while-undeploy/4519>\
**Category:** Product Support\
**Created:** [June 30, 2017, 10:53am UTC](https://forum.opennebula.io/t/error-while-undeploy/4519 "2017-06-30T10:53:59Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Binu](https://avatars.discourse-cdn.com/v4/letter/b/3ab097/32.png) [@Binu](https://forum.opennebula.io/u/Binu)\
**Post date:** [June 30, 2017, 10:53am UTC](https://forum.opennebula.io/t/error-while-undeploy/4519/1 "2017-06-30T10:53:59Z")

</div>

Hi Team,

I am getting error while undeploy a running VM. this VM is running in node and its data store(TM\_MAD = ssh). ssh is running in 22 port, ssh and DNS are working fine. please find the below VM log and give a solution.

Fri Jun 30 16:11:46 2017 [Z0][VM][I]: New LCM state is RUNNING  
Fri Jun 30 16:13:52 2017 [Z0][VM][I]: New LCM state is SHUTDOWN\_UNDEPLOY  
Fri Jun 30 16:14:04 2017 [Z0][VMM][I]: ExitCode: 0  
Fri Jun 30 16:14:04 2017 [Z0][VMM][I]: Successfully execute virtualization driver operation: shutdown.  
Fri Jun 30 16:14:04 2017 [Z0][VMM][I]: ExitCode: 0  
Fri Jun 30 16:14:04 2017 [Z0][VMM][I]: Successfully execute network driver operation: clean.  
Fri Jun 30 16:14:04 2017 [Z0][VM][I]: New LCM state is EPILOG\_UNDEPLOY  
Fri Jun 30 16:14:05 2017 [Z0][TM][I]: Command execution fail: /var/lib/one/remotes/tm/ssh/mv 192.168.10.11:/var/lib/one//datastores/123/31 [front.icsportal.in](http://front.icsportal.in):/var/lib/one//datastores/123/31 31 123  
Fri Jun 30 16:14:05 2017 [Z0][TM][E]: Error creating directory /var/lib/one/datastores/123 at [front.mydomain3.in](http://front.mydomain3.in): ssh: connect to host [front.mydomain3.in](http://front.mydomain3.in) port 22: Connection refused  
Fri Jun 30 16:14:05 2017 [Z0][TM][I]: ExitCode: 255  
Fri Jun 30 16:14:05 2017 [Z0][TM][E]: Error executing image transfer script: Error creating directory /var/lib/one/datastores/123 at [front.mydomain3.in](http://front.mydomain3.in): ssh: connect to host [front.mydomain3.in](http://front.mydomain3.in) port 22: Connection refused  
Fri Jun 30 16:14:05 2017 [Z0][VM][I]: New LCM state is EPILOG\_UNDEPLOY\_FAILURE

---

<div class="post-metadata">

**Author:** ![denis-ldv](https://avatars.discourse-cdn.com/v4/letter/d/b9bd4f/32.png) [@denis-ldv](https://forum.opennebula.io/u/denis-ldv)\
**Post date:** [June 30, 2017, 11:12am UTC](https://forum.opennebula.io/t/error-while-undeploy/4519/2 "2017-06-30T11:12:55Z")

</div>

I may be wrong. But as I understand, script /var/lib/one/remotes/tm/ssh/mv tries to copy disks of VM to frontend. But it cant connect to ssh server.

[https://docs.opennebula.org/5.2/deployment/node\_installation/kvm\_node\_installation.html](https://docs.opennebula.org/5.2/deployment/node_installation/kvm_node_installation.html)  
Step 4

You should configure passwordless ssh from nodes to frontend

---

<div class="post-metadata">

**Author:** ![Binu](https://avatars.discourse-cdn.com/v4/letter/b/3ab097/32.png) [@Binu](https://forum.opennebula.io/u/Binu)\
**Post date:** [June 30, 2017, 11:30am UTC](https://forum.opennebula.io/t/error-while-undeploy/4519/3 "2017-06-30T11:30:35Z")

</div>

Hi denis-ldv,

Thanks for the reply…, its resolved…
