# Fail to start opennebula-sunstone.service

**URL:** <https://forum.opennebula.io/t/fail-to-start-opennebula-sunstone-service/6491>\
**Category:** Installation & Configuration\
**Created:** [October 4, 2018, 9:03pm UTC](https://forum.opennebula.io/t/fail-to-start-opennebula-sunstone-service/6491 "2018-10-04T21:03:45Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![nour](https://avatars.discourse-cdn.com/v4/letter/n/df788c/32.png) [@nour](https://forum.opennebula.io/u/nour)\
**Post date:** [October 4, 2018, 9:03pm UTC](https://forum.opennebula.io/t/fail-to-start-opennebula-sunstone-service/6491/1 "2018-10-04T21:03:45Z")

</div>

I tried to start opennebula:  
systemctl start opennebula : it worked correctly  
systemctl strat opennebula-sunstone: it worked correctly

However, when i tried " one start" it doesn’t work and it displayed this message:  
"Error reading file  
scheduler failed to start "

And “systemctl status opennebula-sunstone.service” displayed:

opennebula-sunstone.service - OpenNebula Web UI Server  
Loaded: loaded (/lib/systemd/system/opennebula-sunstone.service; enabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Thu 2018-10-04 21:46:05 CET; 8min ago  
Process: 21916 ExecStart=/usr/bin/ruby /usr/lib/one/sunstone/sunstone-server.rb (code=exited, status=1/FAILURE)  
Process: 21903 ExecStartPre=/usr/sbin/logrotate -f /etc/logrotate.d/opennebula-sunstone -s /var/lib/one/.logrotate.status (code=exited, stat  
Main PID: 21916 (code=exited, status=1/FAILURE)

أكتوبر 04 21:46:05 nafti-Lenovo-G580 ruby[21916]: :marketplace\_url=\>“[http://marketplace.opennebula.systems/](http://marketplace.opennebula.systems/)”,  
أكتوبر 04 21:46:05 nafti-Lenovo-G580 ruby[21916]: :oneflow\_server=\>“[http://localhost:2474/](http://localhost:2474/)”,  
أكتوبر 04 21:46:05 nafti-Lenovo-G580 ruby[21916]: :routes=\>[“oneflow”, “vcenter”, “support”],  
أكتوبر 04 21:46:05 nafti-Lenovo-G580 ruby[21916]: :session\_expire\_time=\>3600}  
أكتوبر 04 21:46:05 nafti-Lenovo-G580 ruby[21916]: --------------------------------------  
أكتوبر 04 21:46:05 nafti-Lenovo-G580 ruby[21916]: /usr/lib/one/ruby/OpenNebulaAddons.rb:28:in `initialize': No such file or directory @ rb_sys أكتوبر 04 21:46:05 nafti-Lenovo-G580 ruby[21916]: from /usr/lib/one/ruby/OpenNebulaAddons.rb:28:in `new’  
أكتوبر 04 21:46:05 nafti-Lenovo-G580 ruby[21916]: from /usr/lib/one/ruby/OpenNebulaAddons.rb:28:in `initialize' أكتوبر 04 21:46:05 nafti-Lenovo-G580 ruby[21916]: from /usr/lib/one/sunstone/sunstone-server.rb:203:in `new’  
أكتوبر 04 21:46:05 nafti-Lenovo-G580 ruby[21916]: from /usr/lib/one/sunstone/sunstone-server.rb:203:in `’

How can i solve these problems?
