# Failed to open TCP connection to localhost:2633 (connection refused - connect (2) for "localhost" port 2633

**URL:** <https://forum.opennebula.io/t/failed-to-open-tcp-connection-to-localhost-2633-connection-refused-connect-2-for-localhost-port-2633/10400>\
**Category:** Product Support\
**Created:** [March 10, 2022, 2:47pm UTC](https://forum.opennebula.io/t/failed-to-open-tcp-connection-to-localhost-2633-connection-refused-connect-2-for-localhost-port-2633/10400 "2022-03-10T14:47:07Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Thomas](https://avatars.discourse-cdn.com/v4/letter/t/e36b37/32.png) [@Thomas](https://forum.opennebula.io/u/Thomas)\
**Post date:** [March 10, 2022, 2:47pm UTC](https://forum.opennebula.io/t/failed-to-open-tcp-connection-to-localhost-2633-connection-refused-connect-2-for-localhost-port-2633/10400/1 "2022-03-10T14:47:07Z")

</div>

Hello,

I am trying to install Opennebula 6.0 on Debian 10 Buster,  
I followed the quide of Opennebula form the website, But I keep on getting the error

Failed to open TCP connection to localhost:2633 (connection refused - connect (2) for “localhost” port 2633

Could someone help my with this? I have been searching for solutions but couldn’t find one that worked for me.  
When I do netstat -tulnp it doesn’t show the oned 2633 port and if I try to do systemctl start or restart opennebula I get this error message.  
I opened the firewall so that can’t be the issue I believe.  
Hopefully someone knows what I am doing wrong.

Regards,  
Thomas

 ![image](https://canada1.discourse-cdn.com/flex031/uploads/opennebula/original/2X/5/5848e135b258c085583ee161dae6285c9f24abe8.png)  
 ![image](https://canada1.discourse-cdn.com/flex031/uploads/opennebula/original/2X/2/267bd0dc29668700a2f7883fca1beb41b6ccb0af.png)

---

<div class="post-metadata">

**Author:** ![dclavijo](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/dclavijo/32/5265_2.png) [@dclavijo](https://forum.opennebula.io/u/dclavijo)\
**Post date:** [March 11, 2022, 2:00pm UTC](https://forum.opennebula.io/t/failed-to-open-tcp-connection-to-localhost-2633-connection-refused-connect-2-for-localhost-port-2633/10400/2 "2022-03-11T14:00:16Z")

</div>

The main opennebula service (oned) is failing to start. You can probably get more clues about why at `/var/log/one/oned.log`.

---

<div class="post-metadata">

**Author:** ![Thomas](https://avatars.discourse-cdn.com/v4/letter/t/e36b37/32.png) [@Thomas](https://forum.opennebula.io/u/Thomas)\
**Post date:** [March 14, 2022, 8:27am UTC](https://forum.opennebula.io/t/failed-to-open-tcp-connection-to-localhost-2633-connection-refused-connect-2-for-localhost-port-2633/10400/3 "2022-03-14T08:27:44Z")

</div>

I checked /var/log/one/oned.log that specific file was empty. So I checked the file named  
/var/log/one/oned.log-20220310-1646914660 and this was the error I found in that file.

 ![image](https://canada1.discourse-cdn.com/flex031/uploads/opennebula/original/2X/9/986b40cf808170b60bc1ad6c41f75242cd328548.png)  
Do you know this error?

Thank you for your comment

---

<div class="post-metadata">

**Author:** ![Thomas](https://avatars.discourse-cdn.com/v4/letter/t/e36b37/32.png) [@Thomas](https://forum.opennebula.io/u/Thomas)\
**Post date:** [March 14, 2022, 8:37am UTC](https://forum.opennebula.io/t/failed-to-open-tcp-connection-to-localhost-2633-connection-refused-connect-2-for-localhost-port-2633/10400/4 "2022-03-14T08:37:12Z")

</div>

![image](https://canada1.discourse-cdn.com/flex031/uploads/opennebula/original/2X/2/2a8a90a7432818c057f4bb1ed9595ddafa53c2cb.png)  
This is my /etc/one/oned.conf  
Here I have my configuration for my database that I made on the server. I got it enabled and it’s running.

---

<div class="post-metadata">

**Author:** ![Thomas](https://avatars.discourse-cdn.com/v4/letter/t/e36b37/32.png) [@Thomas](https://forum.opennebula.io/u/Thomas)\
**Post date:** [March 15, 2022, 2:07pm UTC](https://forum.opennebula.io/t/failed-to-open-tcp-connection-to-localhost-2633-connection-refused-connect-2-for-localhost-port-2633/10400/5 "2022-03-15T14:07:21Z")

</div>

I managed to fix the problem my system was working yesterday. So end of the day I powered off my opennebula server.  
Today I powered it on again and got a totally different error.  
Cloud controller daemon failed to start and when I looked in /var/log/one/oned.log there was nothing of a error going on.  
But when I looked in /var/log/one/sched.log I found this error. Does someone know how this error  
can suddenly came right after I shutdown the server. And how the fix this error.

 ![image](https://canada1.discourse-cdn.com/flex031/uploads/opennebula/original/2X/1/1013182e71a2017c28276062d1d0b7b759be0461.png)
