# Failed to start opennebula.service

**URL:** <https://forum.opennebula.io/t/failed-to-start-opennebula-service/6527>\
**Category:** Product Support\
**Created:** [October 12, 2018, 12:20pm UTC](https://forum.opennebula.io/t/failed-to-start-opennebula-service/6527 "2018-10-12T12:20:21Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Grzegorz\_Hauska](https://avatars.discourse-cdn.com/v4/letter/g/b3f665/32.png) [@Grzegorz\_Hauska](https://forum.opennebula.io/u/Grzegorz_Hauska)\
**Post date:** [October 12, 2018, 12:20pm UTC](https://forum.opennebula.io/t/failed-to-start-opennebula-service/6527/1 "2018-10-12T12:20:21Z")

</div>

I am following [https://docs.opennebula.org/5.6/deployment/opennebula\_installation/frontend\_installation.html](https://docs.opennebula.org/5.6/deployment/opennebula_installation/frontend_installation.html) and on step 6 I get this error:

Failed to start opennebula.service: Unit opennebula.service not found.

Also /var/log/one catalog does not exists

Ubuntu 17.10.

grzegorz@skynet:~/programming/opennebula-5.6.1$ sudo su oneadmin  
oneadmin@skynet:/home/grzegorz/programming/opennebula-5.6.1$ systemctl start opennebula  
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===  
Authentication is required to start ‘opennebula.service’.  
Authenticating as: Grzegorz, (grzegorz)  
Password:  
==== AUTHENTICATION COMPLETE ===  
Failed to start opennebula.service: Unit opennebula.service not found.

---

<div class="post-metadata">

**Author:** ![Grzegorz\_Hauska](https://avatars.discourse-cdn.com/v4/letter/g/b3f665/32.png) [@Grzegorz\_Hauska](https://forum.opennebula.io/u/Grzegorz_Hauska)\
**Post date:** [October 12, 2018, 12:32pm UTC](https://forum.opennebula.io/t/failed-to-start-opennebula-service/6527/2 "2018-10-12T12:32:06Z")

</div>

I went back and redid package installation and got error about missing libcurl3 after installing it I can start open nebula service easily.

I am pretty sure `apt-get install opennebula opennebula-sunstone opennebula-gate opennebula-flow` succeed before.

---

<div class="post-metadata">

**Author:** ![miljan](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/miljan/32/5119_2.png) [@miljan](https://forum.opennebula.io/u/miljan)\
**Post date:** [October 12, 2018, 5:50pm UTC](https://forum.opennebula.io/t/failed-to-start-opennebula-service/6527/3 "2018-10-12T17:50:50Z")

</div>

Did you try `systemctl unmask opennebula.service` ? One time it worked to me.

> [@Failed to start opennebula.service: Unit opennebula.service is masked](https://forum.opennebula.io/t/failed-to-start-opennebula-service-unit-opennebula-service-is-masked/4753):
>
> I am getting this error while running the command service opennebula start. Please suggest how to resolve this issue.

---

<div class="post-metadata">

**Author:** ![Grzegorz\_Hauska](https://avatars.discourse-cdn.com/v4/letter/g/b3f665/32.png) [@Grzegorz\_Hauska](https://forum.opennebula.io/u/Grzegorz_Hauska)\
**Post date:** [October 13, 2018, 5:33am UTC](https://forum.opennebula.io/t/failed-to-start-opennebula-service/6527/4 "2018-10-13T05:33:01Z")

</div>

What worked for me was to rerun installing packages. Turned out one was missing but I am pretty sure installing packages succeeded before.
