# I need fast help error on creating vm

**URL:** <https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444>\
**Category:** Product Support\
**Created:** [December 17, 2017, 1:02pm UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444 "2017-12-17T13:02:18Z")\
**Posts on this page:** 17\
**Page:** 1

<div class="post-metadata">

**Author:** ![SweGamerHere\_Gamer](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@SweGamerHere\_Gamer](https://forum.opennebula.io/u/SweGamerHere_Gamer)\
**Post date:** [December 17, 2017, 1:02pm UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/1 "2017-12-17T13:02:19Z")

</div>

When i just create a vm

i need to deploy i think i deploy with name node01 and this failure and in vm log is just printed:

Sun Dec 17 13:49:33 2017 [Z0][VM][I]: New state is ACTIVE  
Sun Dec 17 13:49:33 2017 [Z0][VM][I]: New LCM state is PROLOG  
Sun Dec 17 13:49:34 2017 [Z0][TM][I]: Command execution fail: /var/lib/one/remotes/tm/ssh/clone Public-Server:/var/lib/one//datastores/1/13b47bbe0a4905f0a1ff6f9c36dc9a63 node01:/var/lib/one//datastores/0/3/disk.0 3 1  
Sun Dec 17 13:49:34 2017 [Z0][TM][E]: Error creating directory /var/lib/one/datastores/0/3 at node01: ssh: Could not resolve hostname node01: Name or service not known  
Sun Dec 17 13:49:34 2017 [Z0][TM][I]: ExitCode: 255  
Sun Dec 17 13:49:34 2017 [Z0][TM][E]: Error executing image transfer script: Error creating directory /var/lib/one/datastores/0/3 at node01: ssh: Could not resolve hostname node01: Name or service not known  
Sun Dec 17 13:49:34 2017 [Z0][VM][I]: New LCM state is PROLOG\_FAILURE

please help what i have do fail?

Thanks before!

Sorry my bad english

network is configured like this:

template:

BRIDGE = "onebr1"  
DESCRIPTION = "A private network for VM inter-communication"  
DNS = "10.0.0.23"  
GATEWAY = "10.0.0.1"  
PHYDEV = "eth0"  
SECURITY\_GROUPS = "0"  
VN\_MAD = “802.1Q”

and in hosts the node01 host is this a error? Allocated Memory 128MB / - Allocated CPU 10 / 0  
Real Memory 0KB / -

Real CPU 0 / 0

Information  
ID 3  
Name node01   
Cluster default   
State MONITORING\_ERROR   
IM MAD kvm   
VM MAD kvm

Attributes  
ERROR Sun Dec 17 13:52:54 2017 : Error monitoring Host node01 (3): -   
IM\_MAD kvm   
VM\_MAD kvm

Overcommitment Update  
CPU   
0

0  
Memory   
0KB

0KB

another things under vm machine

vm template:

ERROR = "Sun Dec 17 13:49:34 2017 : Error executing image transfer script: Error creating directory /var/lib/one/datastores/0/3 at node01: ssh: Could not resolve hostname node01: Name or service not known"  
LOGO = "images/logos/linux.png"  
SCHED\_MESSAGE = "Sun Dec 17 13:49:25 2017 : Cannot dispatch VM to any Host. Possible reasons: Not enough capacity in Host or System DS, or dispatch limit reached"  
Template  
AUTOMATIC\_DS\_REQUIREMENTS = "“CLUSTERS/ID” @\> 0"  
AUTOMATIC\_REQUIREMENTS = "(CLUSTER\_ID = 0) & !(PUBLIC\_CLOUD = YES)"  
CONTEXT = [  
DISK\_ID = “1”,  
ETH0\_CONTEXT\_FORCE\_IPV4 = “”,  
ETH0\_DNS = “10.0.0.23”,  
ETH0\_GATEWAY = “10.0.0.1”,  
ETH0\_GATEWAY6 = “”,  
ETH0\_IP = “10.0.0.150”,  
ETH0\_IP6 = “”,  
ETH0\_IP6\_PREFIX\_LENGTH = “”,  
ETH0\_IP6\_ULA = “”,  
ETH0\_MAC = “02:00:0a:00:00:96”,  
ETH0\_MASK = “”,  
ETH0\_MTU = “”,  
ETH0\_NETWORK = “”,  
ETH0\_SEARCH\_DOMAIN = “”,  
ETH0\_VLAN\_ID = “”,  
ETH0\_VROUTER\_IP = “”,  
ETH0\_VROUTER\_IP6 = “”,  
ETH0\_VROUTER\_MANAGEMENT = “”,  
NETWORK = “YES”,  
SSH\_PUBLIC\_KEY = “”,  
TARGET = “hda” ]  
CPU = "0.1"  
DISK = [  
ALLOW\_ORPHANS = “NO”,  
CLONE = “YES”,  
CLONE\_TARGET = “SYSTEM”,  
CLUSTER\_ID = “0”,  
DATASTORE = “default”,  
DATASTORE\_ID = “1”,  
DEV\_PREFIX = “vd”,  
DISK\_ID = “0”,  
DISK\_SNAPSHOT\_TOTAL\_SIZE = “0”,  
DISK\_TYPE = “FILE”,  
DRIVER = “qcow2”,  
IMAGE = “ttylinux - kvm”,  
IMAGE\_ID = “0”,  
IMAGE\_STATE = “2”,  
LN\_TARGET = “SYSTEM”,  
ORIGINAL\_SIZE = “200”,  
READONLY = “NO”,  
SAVE = “NO”,  
SIZE = “200”,  
SOURCE = “/var/lib/one//datastores/1/13b47bbe0a4905f0a1ff6f9c36dc9a63”,  
TARGET = “vda”,  
TM\_MAD = “ssh”,  
TYPE = “FILE” ]  
GRAPHICS = [  
LISTEN = “0.0.0.0”,  
PORT = “5903”,  
TYPE = “vnc” ]  
MEMORY = "128"  
NIC = [  
AR\_ID = “0”,  
BRIDGE = “onebr1”,  
CLUSTER\_ID = “0”,  
IP = “10.0.0.150”,  
MAC = “02:00:0a:00:00:96”,  
NETWORK = “Private”,  
NETWORK\_ID = “1”,  
NIC\_ID = “0”,  
PHYDEV = “eth0”,  
SECURITY\_GROUPS = “0”,  
TARGET = “one-3-0”,  
VN\_MAD = “802.1Q” ]  
SECURITY\_GROUP\_RULE = [  
PROTOCOL = “ALL”,  
RULE\_TYPE = “OUTBOUND”,  
SECURITY\_GROUP\_ID = “0”,  
SECURITY\_GROUP\_NAME = “default” ]  
SECURITY\_GROUP\_RULE = [  
PROTOCOL = “ALL”,  
RULE\_TYPE = “INBOUND”,  
SECURITY\_GROUP\_ID = “0”,  
SECURITY\_GROUP\_NAME = “default” ]  
TEMPLATE\_ID = "0"  
VMID = “3”

under templates and vm templates there after is templete  
CONTEXT = [  
NETWORK = “YES”,  
SSH\_PUBLIC\_KEY = “$USER[SSH\_PUBLIC\_KEY]” ]  
CPU = "0.1"  
DISK = [  
IMAGE\_ID = “0” ]  
GRAPHICS = [  
LISTEN = “0.0.0.0”,  
TYPE = “vnc” ]  
LOGO = "images/logos/linux.png"  
MEMORY = “128”

OS i just will install is ttylinux

another log under placements is Sched Message  
Sun Dec 17 13:49:25 2017 : Cannot dispatch VM to any Host. Possible reasons: Not enough capacity in Host or System DS, or dispatch limit reached

Please help im so happy when i get help i didnt know what the problem is please help thanks so much!  
Sorry for my bad english.

---

<div class="post-metadata">

**Author:** ![SweGamerHere\_Gamer](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@SweGamerHere\_Gamer](https://forum.opennebula.io/u/SweGamerHere_Gamer)\
**Post date:** [December 17, 2017, 1:02pm UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/2 "2017-12-17T13:02:59Z")

</div>

Ow i should say im running on esxi and i will create a kvm vm … System: ubuntu server 17.04

---

<div class="post-metadata">

**Author:** ![SweGamerHere\_Gamer](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@SweGamerHere\_Gamer](https://forum.opennebula.io/u/SweGamerHere_Gamer)\
**Post date:** [December 17, 2017, 1:06pm UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/3 "2017-12-17T13:06:58Z")

</div>

brctl show  
bridge name bridge id STP enabled interfaces  
virbr0 8000.525400fa72fd yes virbr0-nic

---

<div class="post-metadata">

**Author:** ![SweGamerHere\_Gamer](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@SweGamerHere\_Gamer](https://forum.opennebula.io/u/SweGamerHere_Gamer)\
**Post date:** [December 17, 2017, 3:04pm UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/4 "2017-12-17T15:04:39Z")

</div>

Please help Hello Someone?!?

---

<div class="post-metadata">

**Author:** ![wusel](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/wusel/32/5076_2.png) [@wusel](https://forum.opennebula.io/u/wusel)\
**Post date:** [December 18, 2017, 5:14pm UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/5 "2017-12-18T17:14:43Z")

</div>

> [@SweGamerHere\_Gamer](#):
>
> `Sun Dec 17 13:49:34 2017 [Z0][TM][E]: Error executing image transfer script: Error creating directory /var/lib/one/datastores/0/3 at node01: ssh: Could not resolve hostname node01: Name or service not known`

That’s your root cause it seems: the system the frontend runs on can’s ssh to oneadmin@node01, as node01 isn’t known. Put it properly into `/etc/hosts` and ensure the hosts file is used for name resolution (check `/etc/nsswitch.conf`).

---

<div class="post-metadata">

**Author:** ![1115](https://avatars.discourse-cdn.com/v4/letter/1/9f8e36/32.png) [@1115](https://forum.opennebula.io/u/1115)\
**Post date:** [December 19, 2017, 10:06am UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/6 "2017-12-19T10:06:53Z")

</div>

i 'm newbie, and may be it’s stupid advice , but try change node1 to host ip. It’s work for me

---

<div class="post-metadata">

**Author:** ![SweGamerHere\_Gamer](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@SweGamerHere\_Gamer](https://forum.opennebula.io/u/SweGamerHere_Gamer)\
**Post date:** [December 19, 2017, 1:21pm UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/7 "2017-12-19T13:21:57Z")

</div>

Hi 1115 I have tested that but this take long time and vnc don,t work and cant reboot the machine or stop the machine but i can test it over the night, tomorrow or today i think and

wusel Can you give me a guide i can linux i good bit but i don,t know what you mean with name resolution check the nsswitch i don,t know what you mean Can you help? i run the server and vms on same machine i didnt run another machines for the frontend frontend is there my vms are i don,t have another computers that work together with the frontend thanks for help but please give me a constucted guide. Thanks again im very newbie too and how long time to setup machine take and more this is on prolog if i choose the machines ip on the host Im happy if i get it too work beaucse i work on to build a web hosting… Thanks…

---

<div class="post-metadata">

**Author:** ![madko](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/madko/32/4195_2.png) [@madko](https://forum.opennebula.io/u/madko)\
**Post date:** [December 19, 2017, 3:15pm UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/8 "2017-12-19T15:15:21Z")

</div>

It’s pretty _simple_, OpenNebula do not use Magic to manage VM. It uses SSH and the user “oneadmin” to manage VM. So if you can’t do ssh node01 from your opennebula host, you loose.

Try this first. Log in on your OpenNebula server as user oneadmin, and try the `ssh node01`  
It will say `ssh: Could not resolve hostname node01: Name or service not known`

To fix that, add your hypervisor hostnames in your /etc/hosts on your OpenNebula server. This should be a line like:  
`IP_NODE01 node01`

Or just read the documentation about OpenNebula installation. Because this is well explained.

---

<div class="post-metadata">

**Author:** ![SweGamerHere\_Gamer](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@SweGamerHere\_Gamer](https://forum.opennebula.io/u/SweGamerHere_Gamer)\
**Post date:** [December 20, 2017, 7:06am UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/9 "2017-12-20T07:06:54Z")

</div>

I have tested but it don,t work i have tested this madko say and that 1115 say but i don,t get it to work i don,t now if i do that correct and wusel i don,t know how you mean can i get more constucted guide?

---

<div class="post-metadata">

**Author:** ![1115](https://avatars.discourse-cdn.com/v4/letter/1/9f8e36/32.png) [@1115](https://forum.opennebula.io/u/1115)\
**Post date:** [December 20, 2017, 8:59am UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/10 "2017-12-20T08:59:34Z")

</div>

Did you use this document , when setuped your node?  
[http://docs.opennebula.org/5.4/deployment/node\_installation/kvm\_node\_installation.html](http://docs.opennebula.org/5.4/deployment/node_installation/kvm_node_installation.html)  
It works anytime , when i do it

---

<div class="post-metadata">

**Author:** ![wusel](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/wusel/32/5076_2.png) [@wusel](https://forum.opennebula.io/u/wusel)\
**Post date:** [January 11, 2018, 2:46am UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/11 "2018-01-11T02:46:15Z")

</div>

> [@SweGamerHere\_Gamer](#):
>
> wusel Can you give me a guide i can linux i good bit but i don,t know what you mean with name resolution check the nsswitch i don,t know what you mean Can you help? i run the server and vms on same machine i didnt run another machines for the frontend frontend is there my vms are i don,t have another computers that work together with the frontend thanks for help but please give me a constucted guide. Thanks again im very newbie too and how long time to setup machine take and more this is on prolog if i choose the machines ip on the host Im happy if i get it too work beaucse i work on to build a web hosting… Thanks…

If you’d have used @wusel, I might have read this earlier … In general it would help to provide proper sentences; I’m not an English native and some of your text doesn’t make sense to me.

That said, `ssh: Could not resolve hostname node01: Name or service not known` tells you what is the issue: there is no target host “node01” within your agreed-upon namespace.

---

<div class="post-metadata">

**Author:** ![SweGamerHere\_Gamer](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@SweGamerHere\_Gamer](https://forum.opennebula.io/u/SweGamerHere_Gamer)\
**Post date:** [January 11, 2018, 8:26am UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/12 "2018-01-11T08:26:41Z")

</div>

Hi i can,t get it to work can someone build a tutorial and send here? or make a script just help me?

---

<div class="post-metadata">

**Author:** ![SweGamerHere\_Gamer](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@SweGamerHere\_Gamer](https://forum.opennebula.io/u/SweGamerHere_Gamer)\
**Post date:** [January 11, 2018, 8:33am UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/13 "2018-01-11T08:33:29Z")

</div>

I will note i using esxi 6.5 can someone help me with a guide what i need to do if i need change settings in esxi on createing the opennebula machine? i have to install a new openenbula someone can guide and give me our own tutorial? how i should do? im would be so happy if i get it to work but someone can write a tutorial to me? and help me how to fix it? i need opennebula so much i being so have if i get some help to get it to work. !!!  
😃

---

<div class="post-metadata">

**Author:** ![SweGamerHere\_Gamer](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@SweGamerHere\_Gamer](https://forum.opennebula.io/u/SweGamerHere_Gamer)\
**Post date:** [January 11, 2018, 8:34am UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/14 "2018-01-11T08:34:25Z")

</div>

I bad on english

---

<div class="post-metadata">

**Author:** ![SweGamerHere\_Gamer](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@SweGamerHere\_Gamer](https://forum.opennebula.io/u/SweGamerHere_Gamer)\
**Post date:** [January 11, 2018, 8:35am UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/15 "2018-01-11T08:35:57Z")

</div>

@1115 @wusel @madko @codinghorror @roman to notice our to get this messages

---

<div class="post-metadata">

**Author:** ![madko](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/madko/32/4195_2.png) [@madko](https://forum.opennebula.io/u/madko)\
**Post date:** [January 11, 2018, 10:10am UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/16 "2018-01-11T10:10:56Z")

</div>

Please stop the spam !

Read the doc :  
[http://docs.opennebula.org/5.4/deployment/node\_installation/kvm\_node\_installation.html](http://docs.opennebula.org/5.4/deployment/node_installation/kvm_node_installation.html)  
and all the others

---

<div class="post-metadata">

**Author:** ![SweGamerHere\_Gamer](https://avatars.discourse-cdn.com/v4/letter/s/34f0e0/32.png) [@SweGamerHere\_Gamer](https://forum.opennebula.io/u/SweGamerHere_Gamer)\
**Post date:** [October 23, 2018, 7:45am UTC](https://forum.opennebula.io/t/i-need-fast-help-error-on-creating-vm/5444/18 "2018-10-23T07:45:26Z")

</div>

I need help with network! [NO IPS in machines help me please](https://forum.opennebula.io/t/no-ips-in-machines-help-me-please/6553)
