# Making VMs through sunstone

**URL:** <https://forum.opennebula.io/t/making-vms-through-sunstone/7977>\
**Category:** Installation & Configuration\
**Created:** [January 14, 2020, 5:02pm UTC](https://forum.opennebula.io/t/making-vms-through-sunstone/7977 "2020-01-14T17:02:53Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![krisibo01](https://avatars.discourse-cdn.com/v4/letter/k/f0a364/32.png) [@krisibo01](https://forum.opennebula.io/u/krisibo01)\
**Post date:** [January 14, 2020, 5:02pm UTC](https://forum.opennebula.io/t/making-vms-through-sunstone/7977/1 "2020-01-14T17:02:54Z")

</div>

I am a student and i have a project that needs me to use opennebula i installed everything and now i am in the sunstone where i am trying to make VMs the problem is that they are staying pending permanently and they doesn’t get host. I made the template for the VMs using Ubuntu18.04 iso and i made the network template using bridged network.

> **[Screenshot](https://prnt.sc/qnn2j4)**
>
> Captured with Lightshot

  

> **[Screenshot](https://prnt.sc/qnn2qx)**
>
> Captured with Lightshot

  
this is screenshots from everything i did in the sunstone until now.

---

<div class="post-metadata">

**Author:** ![dclavijo](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/dclavijo/32/5265_2.png) [@dclavijo](https://forum.opennebula.io/u/dclavijo)\
**Post date:** [January 14, 2020, 11:48pm UTC](https://forum.opennebula.io/t/making-vms-through-sunstone/7977/2 "2020-01-14T23:48:03Z")

</div>

Maybe you don’t have hosts yet ??? You can always manually deploy a VM by selecting a host from the list

---

<div class="post-metadata">

**Author:** ![krisibo01](https://avatars.discourse-cdn.com/v4/letter/k/f0a364/32.png) [@krisibo01](https://forum.opennebula.io/u/krisibo01)\
**Post date:** [January 15, 2020, 12:30am UTC](https://forum.opennebula.io/t/making-vms-through-sunstone/7977/3 "2020-01-15T00:30:50Z")

</div>

I tried to deploy host manually and the status went from PENDING to FAILURE

---

<div class="post-metadata">

**Author:** ![krisibo01](https://avatars.discourse-cdn.com/v4/letter/k/f0a364/32.png) [@krisibo01](https://forum.opennebula.io/u/krisibo01)\
**Post date:** [January 15, 2020, 12:32am UTC](https://forum.opennebula.io/t/making-vms-through-sunstone/7977/4 "2020-01-15T00:32:51Z")

</div>

That is the Log i got from the VM  
Tue Jan 14 19:27:27 2020 [Z0][VM][I]: New state is ACTIVE  
Tue Jan 14 19:27:27 2020 [Z0][VM][I]: New LCM state is PROLOG  
Tue Jan 14 19:27:32 2020 [Z0][TM][I]: Command execution failed (exit code: 255): /var/lib/one/remotes/tm/ssh/ln cyberrange.local:/var/lib/one//datastores/1/34c1c1baade031ed0e1f1f8c049d6154 test-host-2:/var/lib/one//datastores/0/6/disk.0 6 1  
Tue Jan 14 19:27:32 2020 [Z0][TM][E]: Error creating directory /var/lib/one/datastores/0/6 at test-host-2: ssh: Could not resolve hostname test-host-2: Name or service not known  
Tue Jan 14 19:27:32 2020 [Z0][TM][E]: Error executing image transfer script: Error creating directory /var/lib/one/datastores/0/6 at test-host-2: ssh: Could not resolve hostname test-host-2: Name or service not known  
Tue Jan 14 19:27:32 2020 [Z0][VM][I]: New LCM state is PROLOG\_FAILURE

---

<div class="post-metadata">

**Author:** ![dclavijo](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/dclavijo/32/5265_2.png) [@dclavijo](https://forum.opennebula.io/u/dclavijo)\
**Post date:** [January 15, 2020, 3:33pm UTC](https://forum.opennebula.io/t/making-vms-through-sunstone/7977/5 "2020-01-15T15:33:49Z")

</div>

Check the hosts you have in the environment. The frontend is failing to transfer the VM disk to the host cause it cannot resolve its hostname. Make sure the frontend can passwordlessly ssh into the hosts. Carefully read [this](http://docs.opennebula.org/5.10/deployment/node_installation/kvm_node_installation.html#step-4-configure-passwordless-ssh)
