# Problem with migrate virtual machines

**URL:** <https://forum.opennebula.io/t/problem-with-migrate-virtual-machines/8233>\
**Category:** Product Support\
**Created:** [March 19, 2020, 12:20pm UTC](https://forum.opennebula.io/t/problem-with-migrate-virtual-machines/8233 "2020-03-19T12:20:53Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![perrfect](https://avatars.discourse-cdn.com/v4/letter/p/45deac/32.png) [@perrfect](https://forum.opennebula.io/u/perrfect)\
**Post date:** [March 19, 2020, 12:20pm UTC](https://forum.opennebula.io/t/problem-with-migrate-virtual-machines/8233/1 "2020-03-19T12:20:53Z")

</div>

Hi.  
I have two kvm node with VMs.  
I’m testing migrate VMs.  
My system datastore is on LVM.  
When I migrate a running VM i get the error:

> Message received: LOG I 144 Successfully execute transfer manager driver operation: tm\_premigrate.  
> Message received: LOG I 144 ExitCode: 0  
> Message received: LOG I 144 Successfully execute network driver operation: pre.  
> Message received: LOG I 144 Command execution fail: cat \<\< EOT | /var/tmp/one/vmm/kvm/migrate ‘one-144’ ‘node2’ ‘node1’ 144 node1  
> Message received: LOG E 144 migrate: Command “virsh --connect qemu:///system migrate --live one-144 qemu+ssh://node2/system” failed: error: Cannot access storage file ‘/var/lib/one//datastores/129/144/disk.1’: No such file or directory  
> Message received: LOG E 144 Could not migrate one-144 to node2  
> Message received: LOG I 144 ExitCode: 1  
> Message received: LOG I 144 Successfully execute transfer manager driver operation: tm\_failmigrate.  
> Message received: LOG I 144 Failed to execute virtualization driver operation: migrate.  
> Message received: MIGRATE FAILURE 144 Could not migrate one-144 to node2

When I stop my VM, migrate and than start, i get the error:

> Message received: LOG I 141 Command execution fail: cat \<\< EOT | /var/tmp/one/vmm/kvm/deploy ‘/var/lib/one//datastores/129/141/deployment.2’ ‘node1’ 141 node1  
> Message received: LOG I 141 error: Failed to create domain from /var/lib/one//datastores/129/141/deployment.2  
> Message received: LOG I 141 error: Cannot access storage file ‘/var/lib/one//datastores/129/141/disk.0’: No such file or directory  
> Message received: LOG E 141 Could not create domain from /var/lib/one//datastores/129/141/deployment.2  
> Message received: LOG I 141 ExitCode: 255  
> Message received: LOG I 141 Failed to execute virtualization driver operation: deploy.  
> Message received: DEPLOY FAILURE 141 Could not create domain from /var/lib/one//datastores/129/141/deployment.2

Why is it happening and how can decide the problem?

---

<div class="post-metadata">

**Author:** ![feldsam](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/feldsam/32/4441_2.png) [@feldsam](https://forum.opennebula.io/u/feldsam)\
**Post date:** [March 19, 2020, 5:47pm UTC](https://forum.opennebula.io/t/problem-with-migrate-virtual-machines/8233/2 "2020-03-19T17:47:18Z")

</div>

looks like storage is not shared across nodes and frontend.

---

<div class="post-metadata">

**Author:** ![perrfect](https://avatars.discourse-cdn.com/v4/letter/p/45deac/32.png) [@perrfect](https://forum.opennebula.io/u/perrfect)\
**Post date:** [March 20, 2020, 5:32am UTC](https://forum.opennebula.io/t/problem-with-migrate-virtual-machines/8233/3 "2020-03-20T05:32:22Z")

</div>

Thank you for the reply.  
Yes, the problem was with my shared storage.
