# Problems with an upgrade from 5.10.1 to 5.12.0.3

**URL:** <https://forum.opennebula.io/t/problems-with-an-upgrade-from-5-10-1-to-5-12-0-3/9372>\
**Category:** Product Support\
**Created:** [April 8, 2021, 1:50pm UTC](https://forum.opennebula.io/t/problems-with-an-upgrade-from-5-10-1-to-5-12-0-3/9372 "2021-04-08T13:50:27Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Daniel\_Ruiz\_Molina](https://avatars.discourse-cdn.com/v4/letter/d/f08c70/32.png) [@Daniel\_Ruiz\_Molina](https://forum.opennebula.io/u/Daniel_Ruiz_Molina)\
**Post date:** [April 8, 2021, 1:50pm UTC](https://forum.opennebula.io/t/problems-with-an-upgrade-from-5-10-1-to-5-12-0-3/9372/1 "2021-04-08T13:50:27Z")

</div>

Hello,

I’m running an upgrade test (in a OpenNebula that runs in a VM) from 5.10.1 to 5.12.0.3. After browsing OpenNebula web, I found this document [Upgrading Single Front-end Deployments — OpenNebula 5.12.13 documentation](https://docs.opennebula.io/5.12/intro_release_notes/upgrades/upgrading_single.html#upgrading-from-previous-extended-steps). I have done an step-by-step from section “Upgrading from 5.6.x+”. In step 7 “Upgrade the Database version”, system returns an error when tries to do the SQLite DB upgrade:

> [oneadmin@localhost one]$ onedb upgrade -v -s /var/lib/one/one.db  
> Version read:  
> Shared tables 5.10.0 : OpenNebula 5.10.1 (45f6d6df) daemon bootstrap  
> Local tables 5.10.0 : OpenNebula 5.10.1 (45f6d6df) daemon bootstrap
> 
> Sqlite database backup stored in /var/lib/one/one.db\_2021-4-8\_15:39:5.bck  
> Use ‘onedb restore’ to restore the DB.
> 
> > > > Running migrators for shared tables  
> > > > Database already uses version 5.10.0
> 
> > > > Running migrators for local tables  
> > > > Database already uses version 5.10.0
> 
> Total time: 0.10s  
> ERROR: Database upgrade to the latest versions (local 5.10.0, shared 5.10.0)  
> wasn’t successful due to missing migration descriptors. Migrators are  
> provided as part of Enterprise Edition for customers with active subscription.  
> For community with non-commercial deployments they are provided via a  
> dedicated migration package, which must be obtained separately.
> 
> The database will be restored  
> Sqlite database backup restored in /var/lib/one/one.db

I have filled the form to receive the migration packaged and, after I have received email with credentials access, I have seen that migration packages are ONLY to upgrade to 6.0… so, how can I upgrade to 5.12.0.3?

Also, if I run a “onedb fsck” I get these errors/warnings:

> Augeas gem is not installed, run `gem install augeas -v '0.6'` to install it  
> [oneadmin@localhost one]$ gem install augeas -v ‘0.6’  
> Building native extensions. This could take a while…  
> ERROR: Error installing augeas:  
> ERROR: Failed to build gem native extension.
> 
> ```
> /usr/bin/ruby extconf.rb
> 
> ```
> 
> checking for main() in -laugeas… no  
> \*\*\* extconf.rb failed \*\*\*  
> Could not create Makefile due to some reason, probably lack of necessary  
> libraries and/or headers. Check the mkmf.log file for more details. You may  
> need configuration options.
> 
> Provided configuration options:  
> –with-opt-dir  
> –without-opt-dir  
> –with-opt-include  
> –without-opt-include=${opt-dir}/include  
> –with-opt-lib  
> –without-opt-lib=${opt-dir}/lib64  
> –with-make-prog  
> –without-make-prog  
> –srcdir=.  
> –curdir  
> –ruby=/usr/bin/ruby  
> –with-augeaslib  
> –without-augeaslib  
> extconf.rb:37:in `': libaugeas is not installed (RuntimeError)
> 
> Gem files will remain installed in /var/lib/one/.gem/ruby/gems/augeas-0.6.0 for inspection.  
> Results logged to /var/lib/one/.gem/ruby/gems/augeas-0.6.0/ext/augeas/gem\_make.out

So… I need help…

Thanks.

---

<div class="post-metadata">

**Author:** ![derekjkeller](https://avatars.discourse-cdn.com/v4/letter/d/e19adc/32.png) [@derekjkeller](https://forum.opennebula.io/u/derekjkeller)\
**Post date:** [November 7, 2023, 7:17pm UTC](https://forum.opennebula.io/t/problems-with-an-upgrade-from-5-10-1-to-5-12-0-3/9372/2 "2023-11-07T19:17:43Z")

</div>

Hi,

I know this is post is a few years old, but were you able to get the version of the migrator package you needed? If so, how?

Thanks for any information you can provide.

---

<div class="post-metadata">

**Author:** ![amarti](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/amarti/32/6290_2.png) [@amarti](https://forum.opennebula.io/u/amarti)\
**Post date:** [November 8, 2023, 9:11am UTC](https://forum.opennebula.io/t/problems-with-an-upgrade-from-5-10-1-to-5-12-0-3/9372/3 "2023-11-08T09:11:32Z")

</div>

Hi @derekjkeller, at the end of the maintenance cycle of the CE 5.12.x we published a final patch release with the open source migrators: [CE Patch Release v.5.12.0.4 is Available! - OpenNebula](https://opennebula.io/blog/announcements/ce-patch-release-v-5-12-0-4-is-available/) That’s the version you need to migrate to from any previous one 🙂

PS - We only restrict access to the migration packages that apply to the very latest version (now, 6.8) for those organizations that are using OpenNebula CE in production environments for commercial purposes. Anyone else can request them through this simple form: [Get Migration Packages for Latest CE Release](https://opennebula.io/get-migration/)
