Ruby gem and deb package

I still don’t know the rationale because this was added for 5.0.2 (it was not present on 5.0.1). AFAIK the gem version packaged in debian 8 and Ubuntu 16.04 are OK. Probably we’ve just overlooked the version in Ubuntu 14.04.

We’ll look into this to have it working for the next release. Sorry for the problems caused.

Meanwhile you can modify the file /usr/lib/one/oneflow/lib/models/role.rb ad add this gem statement just before the requires:

# Unless required by applicable law or agreed to in writing, software        #
# distributed under the License is distributed on an "AS IS" BASIS,          #
# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.   #
# See the License for the specific language governing permissions and        #
# limitations under the License.                                             #
#--------------------------------------------------------------------------- #

gem 'treetop', '>= 1.6.3'

require 'treetop'
require 'treetop/version'
require 'grammar'
require 'parse-cron'

if !(Gem::Version.create(Treetop::VERSION::STRING) >= Gem::Version.create('1.6.3'))
    raise "treetop gem version must be >= 1.6.3. Current version is #{Treetop::VERSION::STRING}"