# \[SOLVED\] Failure on VM installed from ISO

**URL:** <https://forum.opennebula.io/t/solved-failure-on-vm-installed-from-iso/6859>\
**Category:** Product Support\
**Created:** [February 3, 2019, 1:54pm UTC](https://forum.opennebula.io/t/solved-failure-on-vm-installed-from-iso/6859 "2019-02-03T13:54:10Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![bjohnston](https://avatars.discourse-cdn.com/v4/letter/b/ba8739/32.png) [@bjohnston](https://forum.opennebula.io/u/bjohnston)\
**Post date:** [February 3, 2019, 1:54pm UTC](https://forum.opennebula.io/t/solved-failure-on-vm-installed-from-iso/6859/1 "2019-02-03T13:54:10Z")

</div>

Hello,  
I am new to OpenNebula and trying to install Operating Systems (Ubuntu 18.04 and Windows 7/10) from ISO onto a raw disk image and getting the same error regardless of which ISO I use. For this example of the error I am using an Ubuntu 18.04 Network boot ISO (mini.iso from Ubuntu).

Log of the install:

> Sun Feb 3 05:35:41 2019 [Z0][VM][I]: New state is ACTIVE  
> Sun Feb 3 05:35:41 2019 [Z0][VM][I]: New LCM state is PROLOG  
> Sun Feb 3 05:38:24 2019 [Z0][VM][I]: New LCM state is BOOT  
> Sun Feb 3 05:38:24 2019 [Z0][VMM][I]: Generating deployment file: /var/lib/one/vms/3/deployment.0  
> Sun Feb 3 05:38:25 2019 [Z0][VMM][I]: Successfully execute transfer manager driver operation: tm\_context.  
> Sun Feb 3 05:38:26 2019 [Z0][VMM][I]: ExitCode: 0  
> Sun Feb 3 05:38:26 2019 [Z0][VMM][I]: Successfully execute network driver operation: pre.  
> Sun Feb 3 05:38:27 2019 [Z0][VMM][I]: Command execution fail: cat \<\< EOT | /var/tmp/one/vmm/kvm/deploy ‘/var/lib/one//datastores/0/3/deployment.0’ ‘localhost’ 3 localhost  
> Sun Feb 3 05:38:27 2019 [Z0][VMM][I]: error: Failed to create domain from /var/lib/one//datastores/0/3/deployment.0  
> Sun Feb 3 05:38:27 2019 [Z0][VMM][I]: error: unsupported configuration: target must be 0 for controller model ‘lsilogic’  
> Sun Feb 3 05:38:27 2019 [Z0][VMM][E]: Could not create domain from /var/lib/one//datastores/0/3/deployment.0  
> Sun Feb 3 05:38:27 2019 [Z0][VMM][I]: ExitCode: 255  
> Sun Feb 3 05:38:27 2019 [Z0][VMM][I]: Failed to execute virtualization driver operation: deploy.  
> Sun Feb 3 05:38:27 2019 [Z0][VMM][E]: Error deploying virtual machine: Could not create domain from /var/lib/one//datastores/0/3/deployment.0  
> Sun Feb 3 05:38:27 2019 [Z0][VM][I]: New LCM state is BOOT\_FAILURE

Template used:

> AUTOMATIC\_DS\_REQUIREMENTS = “("CLUSTERS/ID" @\> 0)”  
> AUTOMATIC\_REQUIREMENTS = “(CLUSTER\_ID = 0) & !(PUBLIC\_CLOUD = YES)”  
> CONTEXT = [  
> DISK\_ID = “2”,  
> ETH0\_CONTEXT\_FORCE\_IPV4 = “”,  
> ETH0\_DNS = “172.17.10.25”,  
> ETH0\_GATEWAY = “172.17.11.1”,  
> ETH0\_GATEWAY6 = “”,  
> ETH0\_IP = “172.17.11.13”,  
> ETH0\_IP6 = “”,  
> ETH0\_IP6\_PREFIX\_LENGTH = “”,  
> ETH0\_IP6\_ULA = “”,  
> ETH0\_MAC = “02:00:ac:11:0b:0d”,  
> ETH0\_MASK = “255.255.255.0”,  
> ETH0\_MTU = “”,  
> ETH0\_NETWORK = “172.17.11.0”,  
> ETH0\_SEARCH\_DOMAIN = “”,  
> ETH0\_VLAN\_ID = “”,  
> ETH0\_VROUTER\_IP = “”,  
> ETH0\_VROUTER\_IP6 = “”,  
> ETH0\_VROUTER\_MANAGEMENT = “”,  
> NETWORK = “YES”,  
> SSH\_PUBLIC\_KEY = “\*”,  
> TARGET = “hda” ]  
> CPU = “1”  
> DISK = [  
> ALLOW\_ORPHANS = “NO”,  
> CLONE = “NO”,  
> CLONE\_TARGET = “SYSTEM”,  
> CLUSTER\_ID = “0”,  
> DATASTORE = “default”,  
> DATASTORE\_ID = “1”,  
> DEV\_PREFIX = “sd”,  
> DISK\_ID = “0”,  
> DISK\_SNAPSHOT\_TOTAL\_SIZE = “0”,  
> DISK\_TYPE = “FILE”,  
> DRIVER = “raw”,  
> IMAGE = “Ubuntu 18.04 ISO - SCSI - raw”,  
> IMAGE\_ID = “1”,  
> IMAGE\_STATE = “2”,  
> IMAGE\_UNAME = “oneadmin”,  
> LN\_TARGET = “SYSTEM”,  
> ORDER = “1”,  
> ORIGINAL\_SIZE = “65”,  
> READONLY = “YES”,  
> SAVE = “NO”,  
> SIZE = “65”,  
> SOURCE = “/var/lib/one//datastores/1/b0e2fc65f226a023f1c2f4f056d226df”,  
> TARGET = “sda”,  
> TM\_MAD = “ssh”,  
> TYPE = “CDROM” ]  
> DISK = [  
> ALLOW\_ORPHANS = “NO”,  
> CLONE = “YES”,  
> CLONE\_TARGET = “SYSTEM”,  
> CLUSTER\_ID = “0”,  
> DATASTORE = “default”,  
> DATASTORE\_ID = “1”,  
> DEV\_PREFIX = “sd”,  
> DISK\_ID = “1”,  
> DISK\_SNAPSHOT\_TOTAL\_SIZE = “0”,  
> DISK\_TYPE = “FILE”,  
> DRIVER = “raw”,  
> IMAGE = “HD Test 01 - SCSI - raw - 16gb”,  
> IMAGE\_ID = “2”,  
> IMAGE\_STATE = “2”,  
> IMAGE\_UNAME = “oneadmin”,  
> LN\_TARGET = “SYSTEM”,  
> ORDER = “2”,  
> ORIGINAL\_SIZE = “16384”,  
> READONLY = “NO”,  
> SAVE = “NO”,  
> SIZE = “16384”,  
> SOURCE = “/var/lib/one//datastores/1/fd26139f65b3f1af9baa809c901c6045”,  
> TARGET = “sdb”,  
> TM\_MAD = “ssh”,  
> TYPE = “FILE” ]  
> GRAPHICS = [  
> LISTEN = “0.0.0.0”,  
> PORT = “5903”,  
> TYPE = “VNC” ]  
> MEMORY = “8192”  
> NIC = [  
> AR\_ID = “0”,  
> BRIDGE = “bridge01”,  
> CLUSTER\_ID = “0”,  
> IP = “172.17.11.13”,  
> MAC = “02:00:ac:11:0b:0d”,  
> NETWORK = “default”,  
> NETWORK\_ID = “0”,  
> NIC\_ID = “0”,  
> ORDER = “3”,  
> PHYDEV = “eth1”,  
> SECURITY\_GROUPS = “0”,  
> TARGET = “one-3-0”,  
> VN\_MAD = “bridge” ]  
> OS = [  
> ARCH = “x86\_64”,  
> BOOT = “disk0,disk1,nic0” ]  
> SECURITY\_GROUP\_RULE = [  
> PROTOCOL = “ALL”,  
> RULE\_TYPE = “OUTBOUND”,  
> SECURITY\_GROUP\_ID = “0”,  
> SECURITY\_GROUP\_NAME = “default” ]  
> SECURITY\_GROUP\_RULE = [  
> PROTOCOL = “ALL”,  
> RULE\_TYPE = “INBOUND”,  
> SECURITY\_GROUP\_ID = “0”,  
> SECURITY\_GROUP\_NAME = “default” ]  
> TEMPLATE\_ID = “1”  
> VCPU = “1”  
> VMID = “3”

If any other information is helpful please let me know and I will attempt to provide it.

---

<div class="post-metadata">

**Author:** ![bjohnston](https://avatars.discourse-cdn.com/v4/letter/b/ba8739/32.png) [@bjohnston](https://forum.opennebula.io/u/bjohnston)\
**Post date:** [February 4, 2019, 4:34pm UTC](https://forum.opennebula.io/t/solved-failure-on-vm-installed-from-iso/6859/2 "2019-02-04T16:34:17Z")

</div>

Hello,  
This turns out to be an issue with using SCSI vs IDE for the bus type. As soon as I started using IDE for the CDROM bus type the error went away. If you want or need more information let me know I’ll provide what I can.

Thanks,  
Brian
