# VM startet nicht – Fehler: “DEPLOY: Could not create domain from deployment.0” (KVM)

**URL:** <https://forum.opennebula.io/t/vm-startet-nicht-fehler-deploy-could-not-create-domain-from-deployment-0-kvm/14270>\
**Category:** Installation & Configuration\
**Created:** [October 7, 2025, 5:30pm UTC](https://forum.opennebula.io/t/vm-startet-nicht-fehler-deploy-could-not-create-domain-from-deployment-0-kvm/14270 "2025-10-07T17:30:37Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Deniz23](https://avatars.discourse-cdn.com/v4/letter/d/87869e/32.png) [@Deniz23](https://forum.opennebula.io/u/Deniz23)\
**Post date:** [October 7, 2025, 5:30pm UTC](https://forum.opennebula.io/t/vm-startet-nicht-fehler-deploy-could-not-create-domain-from-deployment-0-kvm/14270/1 "2025-10-07T17:30:37Z")

</div>

Hello everyone,

I need some help, as I am unable to proceed when starting a VM via the OpenNebula web interface (23M) due to the following error message.  
I do not have access to the shell or CLI, but can only use the functions within the web interface.

When starting the VM, this error appears in the log:

Tue Oct 7 15:23:05 2025 [Z0][VM][I]: New state is ACTIVE  
Tue Oct 7 15:23:05 2025 [Z0][VM][I]: New LCM state is PROLOG  
Tue Oct 7 15:23:08 2025 [Z0][VM][I]: New LCM state is BOOT  
Tue Oct 7 15:23:09 2025 [Z0][VMM][I]: Generating deployment file: /var/lib/one/vms/2071/deployment.0  
Tue Oct 7 15:23:11 2025 [Z0][VMM][E]: DEPLOY: Could not create domain from /var/lib/one//datastores/103/2071/deployment.0  
Tue Oct 7 15:23:11 2025 [Z0][VM][I]: New LCM state is BOOT\_FAILURE

The VM then switches to BOOT\_FAILURE status and does not start. I have tried different templates (including with other images), but the error remains the same.

My environment:

Platform: 23M (OpenNebula web interface)

Access: Only via web GUI, no terminal/SSH access

Hypervisor: KVM

Storage: Ceph

Operating system image: Windows Server 2019

settings:

**User template**

```auto
ERROR = "Tue Oct 7 15:23:11 2025: DEPLOY: Could not create domain from /var/lib/one//datastores/103/2071/deployment.0"
HOT_RESIZE = [
  CPU_HOT_ADD_ENABLED = "NO",
  MEMORY_HOT_ADD_ENABLED = "NO" ]
HYPERVISOR = "kvm"
INPUTS_ORDER = ""
LOGO = "images/logos/windows8.png"
MEMORY_UNIT_COST = "MB"
SCHED_DS_REQUIREMENTS = "ID=\"103\""

```

##### **Template**

```auto
AUTOMATIC_DS_REQUIREMENTS = "(\"CLUSTERS/ID\" @> 0)"
AUTOMATIC_NIC_REQUIREMENTS = "(\"CLUSTERS/ID\" @> 0)"
AUTOMATIC_REQUIREMENTS = "(CLUSTER_ID = 0) & !(PUBLIC_CLOUD = YES) & !(PIN_POLICY = PINNED)"
CONTEXT = [
  DISK_ID = "3",
  ETH0_CONTEXT_FORCE_IPV4 = "",
  ETH0_DNS = "212.83.32.201 212.83.33.2",
  ETH0_EXTERNAL = "",
  ETH0_GATEWAY = "62.113.197.1",
  ETH0_GATEWAY6 = "2a00:f48:2000:101f:62:113:197:1",
  ETH0_IP = "62.113.197.3",
  ETH0_IP6 = "2a00:f48:2000:101f:62:113:197:3",
  ETH0_IP6_PREFIX_LENGTH = "120",
  ETH0_IP6_ULA = "",
  ETH0_MAC = "02:00:3e:71:c5:03",
  ETH0_MASK = "255.255.255.0",
  ETH0_METRIC = "",
  ETH0_METRIC6 = "",
  ETH0_MTU = "",
  ETH0_NETWORK = "62.113.197.0",
  ETH0_SEARCH_DOMAIN = "",
  ETH0_VLAN_ID = "56",
  ETH0_VROUTER_IP = "",
  ETH0_VROUTER_IP6 = "",
  ETH0_VROUTER_MANAGEMENT = "",
  NETWORK = "YES",
  TARGET = "hdc" ]
CPU = "4"
CPU_MODEL = [
  MODEL = "host-passthrough" ]
DISK = [
  ALLOW_ORPHANS = "YES",
  CEPH_HOST = "mon01 mon02 mon03",
  CEPH_SECRET = "74ba8d4d-526c-4b50-a399-505da021458a",
  CEPH_USER = "libvirt",
  CLONE = "NO",
  CLONE_TARGET = "SYSTEM",
  CLUSTER_ID = "0",
  DATASTORE = "IMAGE",
  DATASTORE_ID = "102",
  DEV_PREFIX = "hd",
  DISK_ID = "0",
  DISK_SNAPSHOT_TOTAL_SIZE = "0",
  DISK_TYPE = "RBD",
  DRIVER = "raw",
  FORMAT = "raw",
  IMAGE = "Windows_2019_CDROM",
  IMAGE_ID = "835",
  IMAGE_STATE = "2",
  IMAGE_UNAME = "16116-admin",
  LN_TARGET = "NONE",
  ORDER = "1",
  ORIGINAL_SIZE = "5447",
  POOL_NAME = "one",
  READONLY = "YES",
  SAVE = "NO",
  SIZE = "5447",
  SOURCE = "one/one-835",
  TARGET = "hda",
  TM_MAD = "ceph",
  TYPE = "RBD_CDROM" ]
DISK = [
  ALLOW_ORPHANS = "mixed",
  CEPH_HOST = "mon01 mon02 mon03",
  CEPH_SECRET = "74ba8d4d-526c-4b50-a399-505da021458a",
  CEPH_USER = "libvirt",
  CLUSTER_ID = "0",
  DATASTORE = "SYSTEM",
  DATASTORE_ID = "103",
  DEV_PREFIX = "sd",
  DISK_ID = "1",
  DISK_TYPE = "RBD",
  DRIVER = "raw",
  FORMAT = "raw",
  ORDER = "2",
  POOL_NAME = "one",
  SIZE = "102400",
  TARGET = "sda",
  TM_MAD = "ceph",
  TYPE = "fs" ]
DISK = [
  ALLOW_ORPHANS = "YES",
  CEPH_HOST = "mon01 mon02 mon03",
  CEPH_SECRET = "74ba8d4d-526c-4b50-a399-505da021458a",
  CEPH_USER = "libvirt",
  CLONE = "NO",
  CLONE_TARGET = "SYSTEM",
  CLUSTER_ID = "0",
  DATASTORE = "IMAGE",
  DATASTORE_ID = "102",
  DEV_PREFIX = "hd",
  DISK_ID = "2",
  DISK_SNAPSHOT_TOTAL_SIZE = "0",
  DISK_TYPE = "RBD",
  DRIVER = "raw",
  FORMAT = "raw",
  IMAGE = "Windows VirtIO Drivers - v0.1.240",
  IMAGE_ID = "840",
  IMAGE_STATE = "2",
  IMAGE_UNAME = "16116-admin",
  LN_TARGET = "NONE",
  ORIGINAL_SIZE = "599",
  POOL_NAME = "one",
  READONLY = "YES",
  SAVE = "NO",
  SIZE = "599",
  SOURCE = "one/one-840",
  TARGET = "hdb",
  TM_MAD = "ceph",
  TYPE = "RBD_CDROM" ]
FEATURES = [
  ACPI = "yes",
  APIC = "yes",
  HYPERV = "yes",
  PAE = "yes" ]
GRAPHICS = [
  KEYMAP = "de-de",
  LISTEN = "0.0.0.0",
  PORT = "7971",
  TYPE = "VNC" ]
MEMORY = "8192"
NIC = [
  AR_ID = "0",
  BRIDGE = "onebr.56",
  BRIDGE_TYPE = "linux",
  CLUSTER_ID = "0",
  FILTER_IP_SPOOFING = "YES",
  FILTER_MAC_SPOOFING = "YES",
  GATEWAY = "62.113.197.1",
  INBOUND_AVG_BW = "100000",
  INBOUND_PEAK_BW = "125000",
  IP = "62.113.197.3",
  IP6 = "2a00:f48:2000:101f:62:113:197:3",
  MAC = "02:00:3e:71:c5:03",
  NAME = "NIC0",
  NETWORK = "Public-62-113-197--24",
  NETWORK_ID = "6",
  NIC_ID = "0",
  OUTBOUND_AVG_BW = "100000",
  OUTBOUND_PEAK_BW = "125000",
  PHYDEV = "bond1",
  SECURITY_GROUPS = "0",
  TARGET = "one-2071-0",
  VLAN_ID = "56",
  VN_MAD = "802.1Q" ]
OS = [
  ARCH = "x86_64",
  BOOT = "disk0,disk1",
  MACHINE = "pc",
  ROOT = "disk1",
  UUID = "7c270f8e-4307-4260-af35-3aab69b25fe3" ]
SECURITY_GROUP_RULE = [
  PROTOCOL = "ALL",
  RULE_TYPE = "OUTBOUND",
  SECURITY_GROUP_ID = "0",
  SECURITY_GROUP_NAME = "default" ]
SECURITY_GROUP_RULE = [
  PROTOCOL = "ALL",
  RULE_TYPE = "INBOUND",
  SECURITY_GROUP_ID = "0",
  SECURITY_GROUP_NAME = "default" ]
TEMPLATE_ID = "655"
TM_MAD_SYSTEM = "ceph"
VCPU = "4"
VMID = "2071"

```

Questions:

What exactly does the error “DEPLOY: Could not create domain from deployment.0” mean in this context (KVM + Ceph)?

Can this error be fixed by making adjustments to the template (within the web interface)?

Could this be due to incorrect Ceph/disk attributes or the Windows image itself?

I would be very grateful if someone could help me—unfortunately, I’m completely stuck here. 🙏

Best regards,  
Deniz

Screenshots:

> **[Screenshot](https://prnt.sc/U-g_WNrMoq8g)**
>
> Captured with Lightshot

> **[Screenshot](https://prnt.sc/8mIqKX_bX6nR)**
>
> Captured with Lightshot

---

<div class="post-metadata">

**Author:** ![brunorro](https://yyz1.discourse-cdn.com/flex031/user_avatar/forum.opennebula.io/brunorro/32/7590_2.png) [@brunorro](https://forum.opennebula.io/u/brunorro)\
**Post date:** [October 8, 2025, 2:40pm UTC](https://forum.opennebula.io/t/vm-startet-nicht-fehler-deploy-could-not-create-domain-from-deployment-0-kvm/14270/2 "2025-10-08T14:40:27Z")

</div>

Hello,

can you check the status of the datastores and the virtual networks?  
Is the ceph datastore monitored correctly and showing the right free space?

Cheers!

---

<div class="post-metadata">

**Author:** ![Deniz23](https://avatars.discourse-cdn.com/v4/letter/d/87869e/32.png) [@Deniz23](https://forum.opennebula.io/u/Deniz23)\
**Post date:** [October 9, 2025, 9:31am UTC](https://forum.opennebula.io/t/vm-startet-nicht-fehler-deploy-could-not-create-domain-from-deployment-0-kvm/14270/3 "2025-10-09T09:31:14Z")

</div>

Hi,

I’ve checked the status of the datastores and virtual networks (I’m using the **23M web interface only** , without terminal or SSH access).  
Here are my findings:

* * *

**🗄 Datastores:**

- **Datastore 102 (IMAGE)** → Status: **ON** , Type: _IMAGE_, Capacity: _25.6 TB / 29.8 TB (86% used)_

- **Datastore 103 (SYSTEM)** → Status: **ON** , Type: _SYSTEM_, Capacity: _25.6 TB / 29.8 TB (86% used)_

* * *

**🌐 Virtual Networks:**

- **ID 6:** `Public-62-113-197--24`

- **ID 49:** `Shared (vlan30)`

Both networks are active and show no error states.

* * *

Everything looks fine from the GUI side (no “Error” or “Offline” states).  
However, the VM deployment still fails with the following message:

```auto
DEPLOY: Could not create domain from /var/lib/one//datastores/103/2071/deployment.0

```

Do you have any idea if this could be related to Ceph backend permissions, the libvirt secret, or something else that might not be visible from the web interface?

Thanks in advance for your help!

Best regards,  
**Deniz**

---

<div class="post-metadata">

**Author:** ![system](https://canada1.discourse-cdn.com/flex031/uploads/opennebula/original/2X/1/14d66f1130b9cd292905f575da9b68a9f574dd03.png) [@system](https://forum.opennebula.io/u/system)\
**Post date:** [November 8, 2025, 9:31am UTC](https://forum.opennebula.io/t/vm-startet-nicht-fehler-deploy-could-not-create-domain-from-deployment-0-kvm/14270/4 "2025-11-08T09:31:47Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
