Disk cache settings & Live Migration


It seems that, running VMs with multiple disks attached to it, require that the disks have cache setting to ‘none’ for the live migration to work. Is there a way to change/update the disk cache settings of disks that are already attached to running VMs?

Thank you,


Sorry there is no direct way to do so

It seems the way around this is to specify the --unsafe flag in the live-migration. I only feel ok doing this because all disks that were previously attached to VMs, did not have any cache specification at all, so i assume the default with no cache specification also = none. It just wasn’t explicitly selected as ‘none’ so its not recorded as such, causing it to complain.