Error: Storage pool 'default' is of type 'zfs' instead of 'dir'


I am trying to install opennebula but I am getting this error after launching sudo apt-get install opennebula-node-lxd. Please help in providing solution to fix this as this is really delaying the server. I also want to know how to upgrade in the future. I re-install opennebula on my VPS to manage LXD instead of the minione that I was using before. minione is straight forward but I don’t know how to upgrade which leaves me with the option to re-install the server. Please let me know if there is a way to upgrade minione OR if there is a solution to this mention problem so that I can use opennebula with lxd.

When setting up LXD you probably selected ZFS as the backend for the default storage pool. However, if you install the opennebula-node-lxd package, the config should be provided by this package. In any case, you can pass the following config to LXD and expect it to work as intended:

    # Configure LXD daemon
    cat <<EOF | lxd init --preseed
config: {}
cluster: null
networks: []
- config: {}
  description: ""
  name: default
  driver: dir
  - name: default
    description: Default LXD profile  for OpenNebula
       limits.cpu: "1"
       limits.cpu.allowance: 50%
       limits.memory: 512MB
       security.idmap.base: "100000"
       security.idmap.isolated: "true"
       security.idmap.size: "65536"
        path: /
        pool: default
        type: disk