Failed to get shared "write" lock Is another process using the image?

I am using Ubuntu 18.04 as the compute node and opennebula 5.6, When I was trying the opennebula HA, I am getting below error for my vm’s log file,

qemu-system-x86_64: -drive file=/var/lib/one//datastores/101/11/disk.0,format=qcow2,if=none,id=drive-virtio-disk0,cache=none: Failed to get “write” lock.

on opennebula front end side,I see below message on sched.log

Fri May 17 15:43:58 2019 [Z0][SCHED][D]: Match Making statistics:
Number of VMs: 1
Total time: 0s
Total Cluster Match time: 0s
Total Host Match time: 0.00s
Total Host Ranking time: 0.00s
Total DS Match time: 0.00s
Total DS Ranking time: 0.00s

Fri May 17 15:43:58 2019 [Z0][SCHED][D]: Scheduling Results:
Virtual Machine: 11

    PRI     ID - HOSTS
    0       3

    1       101
    0.0464238       103
    0       0

Fri May 17 15:43:58 2019 [Z0][SCHED][D]: Dispatching VMs to hosts:
VMID Priority Host System DS
11 0 3 101

Fri May 17 15:43:58 2019 [Z0][SCHED][D]: Dispatching VMs to hosts. Total time: 0.39s
Fri May 17 15:44:29 2019 [Z0][SCHED][D]: Getting scheduled actions information. Total time: 0.01s
Fri May 17 15:44:29 2019 [Z0][SCHED][D]: Getting VM and Host information. Total time: 0.00s

I dont have any issues on live migrating vms among hosts, only issue is when the host A is powered off, VMs on host A does not move to Host B. The VMs state moves to failure.

Opennebula Front End and Node version - 5.6
Frontend OS - Ubuntu 18.04
Compute Node OS - Ubuntu 18.04
QEMU version on Compute nodes - 2.11

Did you find a solution to this problem, i am facing the same issue.


@kanna909 @shivi how did you work around this issue or even solved it? Tried QEMU 2.11 and upgrade to 4.2.1 didn’t help. Is there any way to just remove lock as I’m sure file is not used?