Kubernetes 1.23 Service download error http 500

Please, describe the problem here and provide additional information below (if applicable) …

I have a 3 host (ubuntu) cluster of OpenNebula with NFS. I want to deploy a Kubernetes cluster. I have been deploying Kubernetes cluster in OpenNebula, as Services, for the past month without any problem.

The kubernetes services I deployed were downloaded from the Apps of One, the versions were 1.18 and 1.21.

I create the cluster from scratch and now in the apps of One you can only download kubernetes 1.23.

The version is not a problem, I cannot download the Service because I receive an error like this:

Searching in /var/logs/one I was able to find in sonstone.log the error.

tail -f 100 /var/log/one/sunstone.log
Mon May 09 13:46:17 2022 [I]: - - [09/May/2022:13:46:17 +0000] "GET /marketplaceapp/571?id=571&csrftoken=c019800ad6fa4d9adfa3961dd3606636f9061078d77089dd89a6da772d6d9627 HTTP/1.1" 200 - 0.1817
Mon May 09 13:46:17 2022 [I]: - - [09/May/2022:13:46:17 +0000] "GET /user/0?id=0&csrftoken=c019800ad6fa4d9adfa3961dd3606636f9061078d77089dd89a6da772d6d9627 HTTP/1.1" 200 - 0.2046
Mon May 09 13:46:18 2022 [I]: - - [09/May/2022:13:46:18 +0000] "GET /vmtemplate?timeout=true&pool_filter=-2&csrftoken=c019800ad6fa4d9adfa3961dd3606636f9061078d77089dd89a6da772d6d9627 HTTP/1.1" 200 - 0.0097
Mon May 09 13:46:18 2022 [I]: - - [09/May/2022:13:46:18 +0000] "GET /marketplaceapp/571?id=571&csrftoken=c019800ad6fa4d9adfa3961dd3606636f9061078d77089dd89a6da772d6d9627 HTTP/1.1" 200 - 0.0078
Mon May 09 13:46:22 2022 [I]: - - [09/May/2022:13:46:22 +0000] "POST /marketplaceapp/571/action HTTP/1.1" 500 - 0.1939
Mon May 09 13:46:32 2022 [I]: - - [09/May/2022:13:46:32 +0000] "POST /marketplaceapp/571/action HTTP/1.1" 500 - 0.3870

It looks like a POST ir having a 500 as response.

OpenNebula version is 6.2.0 on top of Ubuntu 20.04

Hello Julian,

Please take a look at this issue Downloading OneFlow service twice with the same name fails with 500 · Issue #5818 · OpenNebula/one · GitHub.

It’s possible that you have a conflict, you may already have some resources with specific names (like disk images) and that’s causing the error.

Could you try downloading the appliance again, but providing a different name and see if that works for you? :thinking:

Yes, I have tried changing the name of the appliance and trying to download it again, although it gives the same problem.

I have deleted all the VMs and service templates and all disk images. I check it in the console of the ubuntu server when it is running also. When I try to download it with a different name I still receive the same error.

When I look at the template services nothing is there, it is empty.

However it has downloaded a VM template and a VM disk image.

This problem is something that in only happening with this service, with other services for example: Service K3s - Firecracker and Service K3s 1.21.5+k3s2 - KVM it works as expected.

Should I create the service template manually while this is solved?

Thank you for your time

I tried to reproduce your issue in freshly created 6.2.0 ee and ce environments, but I cannot get the same result. Could you maybe repeat the experiment, cleanup existing resources, then retry and share log files /var/log/one/{oned,sunstone,oneflow}.log ? :thinking: