Minione: Script failure on repository due to Apt-Key depreciated

Greeting folks
I am new to the Opennebula world and have hit a snag

The script for Minione fails at repository.

Any help or guidance for a work around or fix would be great.

Though I have tried a classic install, its a lot to work through and I have not yet built up an understanding.

Using Native Ubuntu 22.04 i7 16 GB ram 256 GB HDD

Versions of the related components and OS (frontend, hypervisors, VMs):

Steps to reproduce:

Current results:

Expected results:


Thank you for reporting the issue!

The bug has been just fixed in the 6.8.1 minione release.

Get the minione using that form.

1 Like

Wow, that is awesome
Really great response time
Thanks and Regards

Hi, I have hit another problem, really sorry to be a bother. The repositories are getting stuck again on No valid PGP Data found.

I suspect, the network connectivity is getting disrupted during the virtual interface configuration and the DNS resolution is lost, though I am not sure, you would know better.

Its all good till here, though when the installation fails, I can delete the route and force it to continue.

Then something happens and the name resolution is lost


Ps: In my defense . . . I am banging my way through the classic install, got the front end up and running, trying to figure out the networking

If you still experience that issue, please, try

bash minione --purge

and try install minione again:

bash minione

I’ve just successfully installed minione-6.8.1 on ubuntu 22.04.3 LTS.

Thank you, I tried the purge route, but it failed again.

One work around was to install DNSMasq before minione along with force after deleting the added route to the default bridge.

However :smiley:

I have now done so many installs that I have become quite proficient at the classic install and have successfully got the system up and running.

So now I am onto taking a crack at firedege and VDI configs.

Thank you for the response

It seems like you have some specificity in your setup which is not covered by minione script.
Anyway I am glad you found a way to achieve your goal!
Hope you will enjoy OpenNebula and find it suitable for your tasks!

1 Like

Thank you for the response, really appreciated