Add install_gems dependencie

when i run /usr/share/one/install_gems on ubuntu 14.04.3.

I got this error:

rake="/usr/bin/rake" gem install --no-ri --no-rdoc treetop --version “>= 1.6.3"
Successfully installed treetop-1.6.3
1 gem installed
rake=”/usr/bin/rake" gem install --no-ri --no-rdoc aws-sdk --version "= 1.33"
Building native extensions. This could take a while…
ERROR: Error installing aws-sdk:
ERROR: Failed to build gem native extension.

    /usr/bin/ruby1.9.1 extconf.rb

checking if the C compiler accepts … yes
Building nokogiri using packaged libraries.
checking for gzdopen() in -lz… yes
checking for iconv… yes


IMPORTANT NOTICE:

Building Nokogiri with a packaged version of libxml2-2.9.2
with the following patches applied:

  • 0001-Revert-Missing-initialization-for-the-catalog-module.patch
  • 0002-Fix-missing-entities-after-CVE-2014-3660-fix.patch

Team Nokogiri will keep on doing their best to provide security
updates in a timely manner, but if this is a concern for you and want
to use the system library instead; abort this installation process and
reinstall nokogiri as follows:

gem install nokogiri -- --use-system-libraries
    [--with-xml2-config=/path/to/xml2-config]
    [--with-xslt-config=/path/to/xslt-config]

If you are using Bundler, tell it to use the option:

bundle config build.nokogiri --use-system-libraries
bundle install

Note, however, that nokogiri is not fully compatible with arbitrary
versions of libxml2 provided by OS/package vendors.


Extracting libxml2-2.9.2.tar.gz into tmp/x86_64-pc-linux-gnu/ports/libxml2/2.9.2… OK
Running patch with /var/lib/gems/1.9.1/gems/nokogiri-1.6.6.2/ports/patches/libxml2/0001-Revert-Missing-initialization-for-the-catalog-module.patch…
Running ‘patch’ for libxml2 2.9.2… ERROR, review ‘/var/lib/gems/1.9.1/gems/nokogiri-1.6.6.2/ext/nokogiri/tmp/x86_64-pc-linux-gnu/ports/libxml2/2.9.2/patch.log’ to see what happened.
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=.
–curdir
–ruby=/usr/bin/ruby1.9.1
–help
–clean
–use-system-libraries
–enable-static
–disable-static
–with-zlib-dir
–without-zlib-dir
–with-zlib-include
–without-zlib-include=${zlib-dir}/include
–with-zlib-lib
–without-zlib-lib=${zlib-dir}/lib
–enable-cross-build
–disable-cross-build
/var/lib/gems/1.9.1/gems/mini_portile-0.6.2/lib/mini_portile.rb:279:in block in execute': Failed to complete patch task (RuntimeError) from /var/lib/gems/1.9.1/gems/mini_portile-0.6.2/lib/mini_portile.rb:271:inchdir’
from /var/lib/gems/1.9.1/gems/mini_portile-0.6.2/lib/mini_portile.rb:271:in execute' from extconf.rb:311:inblock in patch’
from extconf.rb:308:in each' from extconf.rb:308:inpatch’
from /var/lib/gems/1.9.1/gems/mini_portile-0.6.2/lib/mini_portile.rb:108:in cook' from extconf.rb:278:inblock in process_recipe’
from extconf.rb:177:in tap' from extconf.rb:177:inprocess_recipe’
from extconf.rb:475:in `’

Gem files will remain installed in /var/lib/gems/1.9.1/gems/nokogiri-1.6.6.2 for inspection.
Results logged to /var/lib/gems/1.9.1/gems/nokogiri-1.6.6.2/ext/nokogiri/gem_make.out
Error executing rake="/usr/bin/rake" gem install --no-ri --no-rdoc aws-sdk --version “= 1.33”

When i run

apt-get install patch

It’s ok.

I think we need add “patch” in package dependencie.

Thank you for reporting!

Fixed in http://dev.opennebula.org/issues/4095