Addind /29 public IP subnet

Hello everyone,
I have just set up my first OpenNebula using sunstone web UI. Everything went well ad exception when I started my first VM where it is running and I can see the console using VNC.

The problem I am having is that I have a /29 public IPv4 addresses and I added this using ip route option to br0. As I said earlier everything finishes fine and I can see that the VM is picking up the IP address but there is no way i can access the VM using the public IP assigned.

Can someone kindly help me out what I am doing wrong here pls?

I am not sure if something else has t be done on the host side apart from adding the subnet to br0.

Apologies in advance if this has been already requested but i couldn’t find help anywhere.

Many thanks

if you can reach the gateway of the /29 from your host via br0, and in opennebula (or sunstone) it shows that an IP is assigned to a VM, that automation part is working fine.
What you prob. didnt do is download+install the context package to the VM (see: and setup (network) contextualization in the template.

must read:

Thanks for your reply and sorry if I missed to explain that part of the question.

The gateway for the subnet is actually the IP address of the host itself (the IP currently assigned to br0). Just to be clear the public IP address that the host has is different from the /29 I have. Network contextualization option is selected in my template and seems to works fine (unless I am doing something wrong). This is where I am getting lost.

I am using opennebula sunstone 4.12 and on the host I have CentOS 7 to give you further details.

thanks again for your help.

assuming your network setup works, did you also install the one-context package in the OS of your VM’s ?

4.12 rpm:
4.12 deb: