Hello all.
I have a Dual AMD Opteron server with 64GB RAM, CentOS 7.6. I installed OpenNebula 5.8.5 as per documentation for Hypervisor KVM and Sunstone on the same machine.

After creating the host configuration (KVM), I added a direct image of Marktplace, a Debian 9 (KVM). When you create a VM from this image, its status is forever “PENDING”.

Checking the status of the server gets ALLOCATED_MEM STAT = err, as shown below.
[root@host01 ~]# onehost list
6 host01 default 0 - - err

The log file /var/log/one/sched.log
Mon Oct 14 15:46:20 2019 [Z0][VM][D]: Found 1 pending/rescheduling VMs.
Mon Oct 14 15:46:20 2019 [Z0][HOST][D]: Discovered 0 enabled hosts.
Mon Oct 14 15:46:20 2019 [Z0][VM][D]: VMs in VMGroups:

Mon Oct 14 15:46:20 2019 [Z0][VNET][D]: Discovered 1 vnets.
Mon Oct 14 15:46:20 2019 [Z0][SCHED][D]: Match-making results for VM 6:
Cannot schedule VM, there is no suitable host.

Mon Oct 14 15:46:20 2019 [Z0][SCHED][D]: Dispatching VMs to hosts:
VMID Priority Host System DS

Has anyone had such a problem?

Hi @lvicentini

You need to look possible errors on /var/log/one/oned.log in order to find what happens with the host. The VM will not run unless a host is OK.

Hello @dclavijo

Is possible, change ssh port to use with opennebula?

Idont use ssh in port 22.

OpenNebula uses SSH for communication between the frontend and the hosts. It should be agnostic to the port where SSH runs on.

Hi @dclavijo, how are you?

When ssh port is default (22), everything works fine, when I change port to (2222) it doesn’t work anymore. Tried to add the port to the file .ssh/config user settings “ondeadmin”, tried to make a new ssh-keyscan -p 2222 after changing the port. Does not work. Any idea?