Browsing hosts on ONE 5.8.1 doesn't work

Please, describe the problem here and provide additional information below (if applicable) …

Browsing hosts on ONE 5.8.1 doesn’t work as expected.

Versions of the related components and OS (frontend, hypervisors, VMs):

Steps to reproduce:

Add, remove or even just browse already added hosts doesn’t work. If I add, the page gets stuck, and only a refresh of the web page brings it up. If I click on it, the page gets stuck again, but after a refresh i’m actually watching the info of the server.

Web inspector dumps this error:
reserved.js:16 Uncaught TypeError: Cannot read property ‘split’ of undefined
at Object. (reserved.js:16)
at Function.each (jquery.js:365)
at Object._updateHostTemplate [as updateHostTemplate] (reserved.js:8)
at Table._elementArray [as elementArray] (datatable.js:122)
at Object. (tab-datatable.js:607)
at Function.each (jquery.js:365)
at Table._updateView [as updateView] (tab-datatable.js:606)
at callback (common-actions.js:46)
at Object.list (action.js:192)
at list (host.js:94)

Current results:

Expected results:

Hello @tosaraja

I have done some tests and it’s working for me. What browser are you using?

When I used firefox to inspect the same thing, I noticed that FF’s console says “TypeError: value.CLUSTER.TEMPLATE.RESERVED_MEM is undefined”. So apparently some setup script from 5.4.x doesn’t work for 5.8.x (or 5.6 as I remember having this same problem back when I tried updating for that).

So I tried going into clusters and noticed the same thing that pages froze. But as I F5’ed the pages and hit the update button for updating the data… then did nothing and closed the update pages, things got fixed. It probably stored the default data that was missing. So I’ll just go through my setup scripts and probably will find something that has changed from 5.4 ->. For instance “RESERVED_CPU=” was previously a fixed number, whereas now it has to be a percentage. Things like that change.

Indeed…RESERVED_MEM has to be defined as well.

Hello @tosaraja

Could you please send me the templates of the hosts and clusters?

@ahuertas The fix for me was to to modify our scripts that automatically set up our openNebula environment. I just had to add the RESERVED_MEM there which was lacking for the new ONE version:

cat > /tmp/cluster <<EOC
onecluster update 0 /tmp/cluster
rm /tmp/cluster

@tosaraja thanks for sharing your solution! We will take a look on that in case there is any bug.