BUG in vCenter with NIC [SOLVED]

Hi! I (and not only me) wrote about this error 3 months ago. There was no response. I recorded a video about this error. This is a critical error.
Error description - After POWER OFF and then POWER ON VM - is automatically added the new network interface.

  1. Open Opennebula. Create new VM. Add Network and deploy.
  2. See in vCenter - VM is deployed and work.
  3. Return to Opennebula and POWER OFF VM.
  4. POWER ON VM
  5. Go to vCenter and we see our VM with MAC conflict and 2 NICs.
  6. Repeat step 3-4 and NICs will be add to infinity!

VIDEO

P.S.Sorry for my English.

Hi Anton!
there’s a ticket http://dev.opennebula.org/issues/4749 related with this problem.

It has already been solved for future releases but if you want to solve your issue, visit the ticket and try to change that line in the vcenter_driver.rb file. It seems that in some situations that line didn’t work as expected and a new NIC with same MAC was created.

Cheers!

1 Like

Hi mcabrerizo!
Thank you for answer! I don’t see ticket on “dev.opennebula.org”. Yours solution helps me!
Thanks!

P.S. Sorry for my English.