Bug report - problem with vms with static mac on it's nic

Please, describe the problem here and provide additional information below (if applicable) …

if i have a vm with a static mac, and i turn it off via opennebula. when i turn it on i get " [Impermissible static ethernet address"

from what i’ve seen, the opennebula do a “reconfig” of the vmx file, and removes the line " **ethernet0.checkMACAddress = “false” from it
if i insert the line manually and turn on the vm from the vcenter, it turnes on fine. but now, the opennebula is unaware of the vm status because he’s not the one to turn it on, so he keeps thinking that the vm is always off.

Versions of the related components and OS (frontend, hypervisors, VMs):
Steps to reproduce:
simply turn off a machine with a static mac, and try to turn it back on via opennebula
Current results:
the vm wont turn on, you get an error stated above
Expected results:

Hi Liorme,

I’ve tried the steps you wrote and i didn’t get the error you said.
The version i’ve tried is 5.8.3 so please, update and try again.
I remind you that operations directly on vcenter server like modify a VM after importing to opennebula is not supported. So actions like poweroff / poweron, doesn’t update the status in opennebula, but if you try to resume a poweron vm this only change its status to running without errors, and the same apply to poweroff.
I attach you an screenshot with the results of following your steps.

  1. Create a VM with static MAC address
  2. Import into OpenNebula
  3. Power on / power off from vcenter
  4. Resume from OpenNebula
  5. PowerOff from OpenNebula
  6. Resume from OpenNebula

As you can see into the image the Instance is running and there is two interfaces with fixed MAC address setting into vcenter previous to import to OpenNebula

Hi. I dont know how to upgrade to 5.8.3, there is some stuff about assembling the package manally that i dont know how to do. So my current version is 5.6.1

Sorry 5.8.3 is a hotfix, you can upgrade to 5.8.1

yeah, i’ve seen that, but i failed to understand how to do the upgrade