Cannot add KVM to opennebula


Below the description of the problem.

We cannot add the kvm to opennebula.

We’ve tried different workarounds.

[root@bdapkvmsbx01 kvm.d]# ls -lah
total 16K
drwxr-x—. 2 oneadmin oneadmin 83 Feb 18 19:02 .
drwxr-x—. 11 oneadmin oneadmin 180 Feb 18 19:02 …
-rwxr-x—. 1 oneadmin oneadmin 2.9K Dec 10 16:55
-rw-r-----. 1 oneadmin oneadmin 4.4K Dec 10 16:55 collectd-client.rb
-rw-------. 1 root root 216 Feb 17 19:27 nohup.out
[root@bdapkvmsbx01 kvm.d]# id
uid=0(root) gid=0(root) groups=0(root) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
[root@bdapkvmsbx01 kvm.d]# ./
bash: ./ Permission denied
[root@bdapkvmsbx01 kvm.d]# ls -lah /bin/bash
-rwxr-xr-x. 1 root root 942K Mar 12 2019 /bin/bash
[root@bdapkvmsbx01 kvm.d]# /bin/bash
allexport off
braceexpand on
emacs off
errexit off
errtrace off
functrace off
hashall on
histexpand off
history off
ignoreeof off
interactive-comments on
keyword off
monitor off
noclobber off
noexec off
noglob off
nolog off
notify off
nounset off
onecmd off
physical off
pipefail off
posix off
privileged on
verbose off
vi off
xtrace off line 100: set: -s: invalid option
set: usage: set [-abefhkmnptuvxBCHP] [-o option-name] [–] [arg …]
[root@bdapkvmsbx01 kvm.d]# getenforce
[root@bdapkvmsbx01 kvm.d]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.7 (Maipo)

Hello @gdobrescu

What error are you getting when you try to create the host?


Hello @gdobrescu , you probably have your /var/tmp on KVM nodes mounted with noexec option. Best, Vlastiml