Certificate verification failed: The certificate is NOT trusted!

Good morning every one

I tried to install opennebula version 6.0 (on ubuntu 20.04 LTS) after going through the following steps:

apt update

apt-get -y install gnupg wget apt-transport-https

wget -q -O- https://downloads.opennebula.org/repo/repo.key | sudo apt-key add -

echo “deb Index of /repo/6.0/Ubuntu/20.04 stable opennebula” > /etc/apt/sources.list.d/opennebula.list

So far everything is perfect but after that wen i execute :

apt-get update

i get this error message :pensive: :

Err :6 Index of /repo/6.0/Ubuntu/20.04 stable Release **
** Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate. Could not handshake: Error in the certificate verification. [IP : 443]

can you help me please

Note: the same problem with opennebula 5.12

thank you

What happens when you run

apt install ca-certificates


1 Like

Hi @tarek,

As @remy said you need to update the CA certificates.


apt install ca-certificates… is done with success
after installing ca-certificates, I tried the update again. the new error message is:

Ign :6 Index of /repo/5.12/Ubuntu/20.04 stable InRelease

what should i do now
1000 thanks

Did you really run

echo “deb Index of /repo/6.0/Ubuntu/20.04 stable opennebula” > /etc/apt/sources.list.d/opennebula.list

or is that the forum software replacing stuff? Your opennebula.list file should contain:

deb https://downloads.opennebula.io/repo/6.0/Ubuntu/20.04 stable opennebula

everything is perfect thank youuuuu

1 Like