"Peer's Certificate has expired."

Hi all,

Just trying to install a new CentOS host. When I run the “yum install” command it fails with: [Errno 14] curl#60 - “Peer’s Certificate has expired.”

I tried retrieving the GPG key directly using wget(1) but that returned:
ERROR: cannot verify’s certificate, issued by ‘/C=US/O=Let’s Encrypt/CN=R3’:
Issued certificate has expired.

which I kind-of expected but tried it “just in case”.

Any idea who to speak to about getting the key updated?

Hello @MartinW,

IMHO server certificate is fine

  • Issued On Thursday, December 10, 2020 at 2:13:54 PM
  • Expires On Wednesday, March 10, 2021 at 2:13:54 PM

Do you have correct current time on your machine?

Do you have your system updated?

Can you please provide verbose output from your curl (curl -vvv

Thank you,

Hi Vlastimil,

Thanks very much for the quick response. It turns out that my carefully-installed ntp daemon hadn’t started and the date was off by about ten months!

Sorting that out has resolved the problem. My apologies for disturbing you with such a simple problem.