Disabled IPV6 and 802.1Q VLANs


We don’t use/configure IPV6 so we have it disabled in our servers.

I am trying to setup VLAN based Virtual Networks. I obviously only assign IPV4 addresses.

However when I try to start VMs I get IPV6 error messages:

Mon Nov 13 06:44:16 2017 [Z0][VMM][I]: ip6tables v1.4.21: can't initialize ip6tables table `filter': Address family not supported by protocol
Mon Nov 13 06:44:16 2017 [Z0][VMM][I]: Perhaps ip6tables or your kernel needs to be upgraded.
Mon Nov 13 06:44:16 2017 [Z0][VMM][E]: post: Command Error: sudo ip6tables -S
Mon Nov 13 06:44:16 2017 [Z0][VMM][E]: post: ["/var/tmp/one/vnm/command.rb:62:in `block in run!'", 

My guess is that it is trying to apply default IPV6 rules for when no IPV6 is configured.

However, what can I do if IPV6 is disabled completely?

Looks like you have to install ip6tables on compute nodes or update vnm driver to not run ip6tables command.

There is no check about network have/not have ipv6 configured in security groups.

You can open issue on dev.opennebula.org or update that file on frontend node and them onehost sync --force to update that file (by removing ip6tables cmds) on compute nodes also

ip6tables is installed.

I basically turn off the IPv6 stack by providing a kernel switch at boot time. So, any attempt to deal with ipv6 kernel objects just fails.

I am not experiencing any issues with the BRIDGE network driver.

But the VLAN driver will mess ipv6 tables even if you don’t setup ipv6 addressing.

I will open an issue…

Hello, I understand. So you have to temporary update that driver by deleting ip6 sections and open issue on github, because redmine was discontinued few days ago