Econe-run-instances fail

On a stable system that has been installed for 2 years, and no intentional changes have been made, I am having the following issue: (said command below worked as recently as last week).

econe-run-instances --access-key=/tmp/x509up_u2904 --secret-key=/tmp/x509up_u2904 --user-data=timmtest --type=glideinwms.4cpu --url ami-00000005

econe-run-instances: select(): Operation now in progress

Both the client and server software come from OpenNebula 4.8. The following statements are true:

  1. I get this error with all econe-* commands
  2. It’s known to be a very low-level socket error, signifying that you cannot open the socket
  3. The error persists against two different servers
  4. the same econe-run-instances command that is run on the server itself works
  5. the econe-server is running normally and can still launch virtual machines when accessed via other clients
  6. I installed a new machine with client software and I get the same error
  7. reboot of the client machine doesn’t help, neither does restart of the econe-server
  8. The only difference I can see is that the version of the “curb” ruby gem is different between client and server.

-bash-4.1$ gem list curb

*** LOCAL GEMS ***

curb (0.9.2, 0.9.1, 0.9.0, 0.8.8)

[root@fclheadgpvm01 ~]# gem list curb

*** LOCAL GEMS ***

curb (0.8.8)

Could the version of the curb gem be the issue? If so is there a way to force econe-* utilities to use the older version, and to back-install said older version where I don’t have it?

On a test instance I have verified that if I delete the latest curb version 1.9.3
and install 1.8.8 then econe-run-instances and friends work where they didn’t previously.
The question is–is there any way to force econe-run-instances to use the old 1.8.8
version of the curb ruby gem while both are installed?
Because I believe what is happening is that the newer version of the gem is getting
auto-installed by puppet’s gem provider.

also is there a way to make “econe” not get auto-corrected to scone or cone?


I have further verified that versions of curb up to 1.9.1 work but newer ones do not.

Just clarifications here: every place above hat I have curb 1.9.3 or 1.9.1 or 1.8.8
it should be 0.9.3, 0.9.1, 0.8.8.

0.9.1 is good. 0.9.3 is not good and it was the installation of 0.9.3 (automatedly)
that broke my setup. I have figured out the puppet necessary to make the gem
not upgrade.

However the real question–is a fix possible to the library
(on which all of the econe clients depend) so that it will work with modern versions of the curb gem?
For that matter, there’s been talk for years that these econe- clients will eventually
be deprecated, has that happened yet?