Ruby 1.9.3 needed to run latest code source

Hi all,

Please update documentation at the source for OpenNebula One project. Currently the documentation states that you need Ruby version >= 1.8.5, but with recent code changes, you need a version higher than >= 1.9.3 as any version lower than this does not understand grouping.

tail -f /var/log/one/sunstone.*
==> /var/log/one/sunstone.error <==
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require': /usr/lib/one/ruby/vcenter_driver.rb:342: undefined (?...) sequence: /^one-(?<id>\d*)(-(?<tail>.*))?$/ (SyntaxError) /usr/lib/one/ruby/vcenter_driver.rb:716: undefined (?...) sequence: /^one-(?<id>\d*)(-(?<tail>.*))?$/ from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from /usr/lib/one/sunstone/routes/vcenter.rb:26
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require' from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from /usr/lib/one/sunstone/sunstone-server.rb:363
from /usr/lib/one/sunstone/sunstone-server.rb:362:in `each’
from /usr/lib/one/sunstone/sunstone-server.rb:362

It seems this code was introduce recently. I had to install version 1.9.3 in order for me to make the SunStone application and the VNC proxy to start properly.


We’ve changed the code so it is compatible with ruby 1.8.7+

Thanks a lot for your feedback!

Thanks Tino. I have validated that the code changes work with 1.8.7 again. Much appreciated.