Fs_lvm with raw driver doesnt work with shared tm - 5.8


I recently upgraded a 5.6 installation to 5.8.1 and am not able to deploy VMs. We have an image datastore with fs_lvm and we use raw drivers. We have a System Datastore with shared driver

When we deploy a VM, we get an error as follows “[one.vm.deploy] Image Datastore does not support transfer mode: shared”

I have seen similar problems reported on qcow2/ssh for which there was a fix mentioned on the issue Image Datastore does not support transfer mode: ssh

I tried copying the latest TM_MAD_CONF from https://github.com/OpenNebula/one/blob/master/share/etc/oned.conf but still the same error.

I see that in 5.8, TM_MAD includes a list of compatible system datastores as per Ruben.

I tried using COMPATIBLE_SYS_DS as per documentation but that doesn’t help either with the error

Am I missing something here ? Does it require a custom TM_MAD_CONF for it to work with fs_lvm ?


The solution seems to be to add TM_MAD_SYSTEM to the virtual machine templates as per http://docs.opennebula.org/5.8/deployment/open_cloud_storage_setup/fs_ds.html

To select the (alternate) deployment mode, add the following attribute to the Virtual Machine template:

  • TM_MAD_SYSTEM="ssh"

We modified our template to shared and the VMs are getting deployed now

Wondering if there is a way to make this behavior as default as we have hundreds of templates and manually updating them could be cumbersome

we also modified the system datastore to be fs_lvm type and it worked without impact after the upgrade to 5.12

1 Like

appreciate the update, thanks!