Group mappings with OpenLDAP

I am having issues with mapping my LDAP groups to OpenNebula groups. The documentation around group templates and generation of the Server1.yaml files was a bit unclear. I was able to add GROUP_DN to my Group template, but my user account is still not mapping to the OpenNebula group that contains that entry. I also tried to manually add the information to the server1.yaml file without any success. Below is my ldap_auth.conf settings and my server1.yaml settings. Any help would be appreciated.


server 1:

  :user: 'cn=admin,dc=ldapdomain'

  :password: '**********'


  :auth_method: :simple


  :host: ldapserv

  :port: 389


  :base: 'dc=ldapdomain'

  :group_base: 'ou=Group,dc=ldapdomain'


  :user_field: 'uid'


  :group_field: 'memberUid'


  :user_group_field: 'uid'


  :mapping_generate: false


  :mapping_timeout: 300


  :mapping_filename: server1.yaml


  :mapping_key: GROUP_DN

  :mapping_default: 1


  :rfc2307bis: true


cn=admins,ou=Group,dc=ldapdomain: ‘100’

100 is the ID of my opennebula group