Increasing VM monitoring time

Hello,

I would like to increase VM monitoring time. By default, each 30 seconds OpenNebula runs a monitoring process for all VMs. In my scenario, sometimes server is running more than 450 VMs. I think that server could monitor in 300 seconds (5 minutes) interval. I have modified some parameters in /etc/one/monitord.conf:

#MANAGER_TIMER = 15
MANAGER_TIMER = 60
MONITORING_INTERVAL_HOST = 180
#HOST_MONITORING_EXPIRATION_TIME = 43200
HOST_MONITORING_EXPIRATION_TIME = 0
#VM_MONITORING_EXPIRATION_TIME = 43200
VM_MONITORING_EXPIRATION_TIME = 0

and other parameter in /etc/one/sched.conf

SCHED_INTERVAL = 30
MAX_VM       = 50
###MAX_VM       = 5000
MAX_DISPATCH = 30
MAX_HOST     = 20

However, OpenNebula continues running a monitoring process each 30 seconds.

What have I done wrong?

Thanks.

https://docs.opennebula.io/6.0/installation_and_configuration/opennebula_services/monitoring.html#adjust-monitoring-intervals

I think you may be interested in the PROBES_PERIOD attribute array. After changing it you need to restart the agents and opennebula.

Hi,

I have configured PROBES_PERIOD array in this way:

PROBES_PERIOD = [
BEACON_HOST = 120,
SYSTEM_HOST = 600,
MONITOR_HOST = 120,
STATE_VM = 120,
MONITOR_VM = 300,
SYNC_STATE_VM = 180
]

but after restarting opennebula, opennebula-hem and opennebula-scheduler daemons, ONE is checking VM in a 30 seconds interval (old value), and not in 120 seconds interval (new value)…

Hi,

The VM monitoring is done on the hosts so you should try restarting the monitoring daemon there too. Disable/enable the hosts and then an onehost forceupdate should restart the monitoring.

BR,
Anton