Kubernetes Appliance stuck in Deploying state


I have downloaded Kubernetes Appliance from the marketplace. I have created two virtual networks, one public and private and instantiated the service but VNF is struck in Deploying state and all the other roles are in pending state. Is there anything i am missing? I am attaching the screenshots below.


I had exactly the same issue.
I solved this issue in this way due to the connection between the onegate server and the vms.

The vnf must contact the onegate server to send ready info.

Check in the vnf vm if it can contact onegate server (onegate vm show). If you have some error, may be the address of the onegate server in oned.conf is not good.
The onegate server has to be in the same network than your public network.

If it’s right, enter in your vm and try this command : onegate vm update --data "READY=YES"
This command is a command present on one of the appliance scripts.
It send the good message to onegate, and the service could continue.

In my case, master and storage work perfectly but the worker doesn’t work. (no connection to the master).

Best regards

Hello Olivier,

Thank you for your reply. How do i login to the VNF instance, when i click on the VNC icon its prompting me for localhost login and password, but i didnt set credentials, so how do i login?

Also, on etc/one/oned.conf file, i have set onegate_endpoint as “”, shouldnt this enable the communication between the VM’s and onegate server?

sorry for the delay.

If you have defined a user with a public key (oneadmin for example created during the installation of one), you need to copy the private key in your computer and connect to you vm with it.
You can create your own rsa key. In this case, create a new user in One and copy your public key in the auth part of the user.
One is going to copy this public key into the vm for ssh connection.
You can just add the public key by editing the vm → conf update → context → and add the public key into the SSH public key.
The ssh user by default is root.

You can add PASSWORD key into context with a password that you’ve defined.
The context will be update and you could connect yourself this root login and the password.

in oned.conf, the documentation indicate a specific address here :

# OneGate
#   ONEGATE_ENDPOINT: The URL for the onegate server (the Gate to OpenNebula for
#   VMs). The onegate server is started using a separate command. The endpoint
#   MUST be consistent with the values in onegate-server.conf

ONEGATE_ENDPOINT = "http://xxx.xxx.xxx.xxx:5030"

In the template of your vm (the tab template on the vm section), you could see the information:

ONEGATE_ENDPOINT = "http://xxx.xxx.xxx.xxx:5030"

You could check the address of the onegate in the vm. If you place a, in the config, the vm couldn’t know the endpoint address.

best regards

Hello Olivier,

I was able to login to the VNF, when i try the command “Onegate VM show” it says "Failed to open TCP Connection to

I am using OVS to do the networking and here are my networks.

I have three virtual networks in sunstone, ( Public) and ( private) and instantiating the Kubernetes service with networks as public and

These are all the changes i have made to the oned.conf, onegate-server.conf and oneflow-server.conf

Could you please have a look and tell me where i can make changes ? Thank you

Thanks Olivier, i have changed my onegate endpoint and oneflow server and it worked.

Using this start to deploy, but the issue is, VNF router contacted all nodes but connect with only master node, worker node & storage node was “no usable master found error.”


Hello Jagathees_b,

  1. It seems your onegate setup looks working. :+1:
  2. The problem seems to be either routing/NAT not running on VNF or some more general networking issue. :-1:

If you could share:

oneflow show <oneflow id here> -j | jq -r .DOCUMENT.TEMPLATE.BODY.custom_attrs_values

and xml from both VNETs you use to deploy the service. Then we could maybe understand more what is happening in your environment. :thinking:

Hi mopala,
Below mentioned my output, networking is correct check where i have wronged.

Public VNET:
Private VNET:
Control Plane VIP:


thank you for those listings. It all looks correct. So if you claim that there is no networking issue, then pehaps it’s simply a performance issue (you can see the timeout on the screenshot above). So we’ve seen such issues for example when hypervisor in OpenNebula is set to “qemu” instead of “kvm”. That’s my guess. :thinking: