Network with OneContext and VSphere

Hello there,

I am just starting with OpenNebula, so forgive me if i already have made a terrible mistake regarding the documentation so far.
I have one ESXI Host with a VCenter and a Ubuntu VM with OpenNebula installation on top. They are both Connected to a VMNetwork and are working fine. After updating to the github master branch of OpenNebula i could import the 2 wild VMs as well. Now I made a new VM with vSphere and marked it as a template (ubuntu vm with open vm tools and one context installed via dpkg and apt install -f) and imported this template to OpenNebula. In OpenNebula i edited the template and filled it with basic variables for the one context package (hostname, ssh key etc.). They all work except networking:

I used as a reference for the variables to set.


I tried as well to set the values for ETH0 static, but this does not work as well. The hostname is set, but /etc/network/interfaces is only filled with the lo interface.

Did i mess up something here? can i find anymore informations about one-context?
Might add as well that i get a timeout on the start job dev/disk-by-\x2dlabel-CONTEXT.device. The only information about that here in the forum was one guy who had just removed the target line from the service file, but i don’t think this should be a general fix?

If i add a DHCP configuration in the VM (via VNC console) it gets a IP and stuff.

Any help would be greatly appreciated


Versions of the related components and OS (frontend, hypervisors, VMs):

  • ESXI 6.5 with vSphere Client


  • Opennebula on Ubuntu 16.04
  • vSphere Server Apliance (CentOS fork called PhotonOS)
  • TestVM With Ubuntu 16.04 as well

Okay i think i found my error in the imported VM Network from vSphere.
The imported Network only had a Ether Range set and no other information about the default gateway, dns, vlan and so on. i deleted the initial ethernet range and added a IPv4 Range with the necessary attributes i know from esxi and now it works.

is this a import bug from vcenter to opennebula, or is this intended?
I still get the Timeout on dev/disk-by-\x2dlabel-CONTEXT.device thou