No Network in VM - Err: eth0 is not a recognised interface


I have installed OpenNebula 5.4.1 on Ubuntu 16.04 using KVM as the hypervisor.
I have followed the instructions at to install the front end and the nodes on the same desktop.

My interface in Ubuntu is called enp3s0 and here is a picture of the /etc/network/interfaces file.

I have set up the bridge br0 as specified in the interfaces file above. Using brctl show I get

I have tried to set up a Virtual Network in OpenNebula. Here is a screenshot of my configuration.

i assigned the address range to be

I then try to create the ttylinux-kvm VM as specified in the ‘Verify your Installation Section’. I assign the Virtual Network to the VM template.

However, when I launch the ttylinux - kvm VM, I get the error ‘eth0 is not a recognised interface’. Here is a screenshot of the error.

Has anyone had a similar error and managed to rectify it?

I would be extremely grateful for any help in the matter!
Please let me know if you need more information.

Kind regards,

Anne Marie

Hi Anne Marie,

You should set the hardware model for the nic to virtio in the VM template:

You could also select default network too.

Best Regards,
Anton Todorov

Hi Anton,

Thanks for your reply!

Do I set the hardware model anywhere else apart from the VM template?

Unfortunately I don’t have a default network so I’ll have to set up my own.
Should I just assign the bridge name or should I provide the Contextualization options aswell when setting up the virtual network?

Thanks for your help! I really appreciate it.

Kind regards,

Anne Marie

Hi Anne Marie,

AFAIK all appliances in the OpenNebula Marketplace has no network assigned by default so after importing the appliance you must update the template to assign a network to it. It looks like the “test bridge” network config visible in the screen shot that you’ve posted should be ok.

Regarding the hardware model, it is possible to set a default value in /etc/one/vmm_exec_kvm.conf - just un-comment the line regarding the NIC defaults. Not sure is it needed to restart the opennebula service so I recommend to restart it after editing the configuration files in /etc/one/* :slight_smile:

Best Regards
Anton Todorov