result FAILURE [] User couldn't be authenticated, aborting call


Trying the latest Medusa with MySQL

GUI works fine, downloading images from market works fine. Added localhost successfully.

Tried to instantiate Ubuntu LXD from market and it get in stuck in PROLOG phase.

It seems like authentication of serveradmin does not work?



hash in /var/lib/one/.one/

is different from the hash in the user_pool table:

! removed by hand for the forum

Is it correct?

If I change the hash in the database, I cannot login to GUI anymore.

Shall I change the hash in files to the:

Tried to change hash in files, it does not help.

How to verify connection from scheduler to oned from command line manually?

CLI commands like

oneuser list
onevm list

work fine

Shall I do the same as:

Thank you kindly for your patience and assistance :-). I have updated the OpenNebula DB with hash of oneadmin new password and things got back to normal. Honestly I don’t know what happened, I have just inherited this ONE deployment.


cat one_auth

echo XXX | openssl sha1
(stdin)= a3e2b09a9908bc5e7c17b5fcdb50718db9f8891e


Why hashes are different?


‘echo XXX’ appends an line termination character at the end
you should try with ‘echo -n XXX | openssl sha1’

Best Regards,
Anton Todorov

From you log files, it seems that the problem is just with the scheduler. The scheduler should be run as oneadmin with access to the oneadmin credentials.

Problem with scheduler was related to fireholl settigns strict even to localhost connections

About hashes, I will try once again, but if I remember correct later I tried bash -n too