Users not login in Sunstone


I use Opennebula 5.6.2, and this week users can’t authenticate in Sunstone. When try authenticate, return this message:

“OpenNebula is not running or there was a server exception. Please check the server logs.”

In oned.log, have this message:

[Z0][ReM][D]: Req:2416 UID:-1 invoked
[Z0][ReM][E]: Req:2416 UID:- result FAILURE [] User couldn’t be authenticated, aborting call

Via CLI, using oneuser is working OK. I’ve already checked it one_auth file, and changed oneuser password in database and one_auth file, but this not resolved.

If you put incorrect password in Sunstone, returns “Incorrect Password”. The error occurs just password is correct.

Strange it was working and no change was made.

Can anyone help-me?

I solved this problem. The database was corrupted. After I restored DB, Sunstone worked ok.

1 Like

I am facing the exact problem. I dont have DB backup . How can fix it?

@vasanthsg, I my case, the problem was in table user_pool. If you have the same problem, you need check user_pool table.

An ideia is make backup of this table then truncate it. Then, of a clean instalation, copy register of oneadmin account. I think that this be suficcient for do login in sunstone with oneadmin account. If it is works, you import register by register, until find the broken register.