OpenNebula 5.0 - LizardFS TM


I’m already using lizardfs for nfs storage. tm_mad is qcow2 for images and shared for system datastore.
In there’s a tm for moosefs.

I tried to apply it, placed the files, and added below to oned.conf:
TM_MAD = [
name = “tm_moosefs”,
executable = “one_tm”,
arguments = “tm_moosefs/tm_moosefs.conf” ]

Then tried to create a new datastore bot got error:
[oneadmin@fe1 ~]$ cat ds_tm.conf
NAME = mfs_images
DS_MAD = fs
TM_MAD = tm_moosefs

[oneadmin@fe1 ~]$ onedatastore create ds_tm.conf
[DatastoreAllocate] TM_MAD named “tm_moosefs” is not defined in oned.conf

So what am i missing, and if it works, what will be benefits over my current config (qcow2 for images)?


Ok it seems that the instructions in the link and the scripts doesnt apply to OpenNebula 5.0
I’ll try to adapt and let know once I do…

@silbogg - Any update on the scripts LizardFS/Moosefs TM, We tried and we were also unsuccessful.

Could anyone share the latest instruction or drivers for LizardFS/Moosefs for ONE 5.0