Opennebula 5.8.4 freshly installed, can't import most vms

Please, describe the problem here and provide additional information below (if applicable) …
can’t import most vms into the system. when clicking import vms, nothing happens. no error, no circle that’s loading the vm.

Versions of the related components and OS (frontend, hypervisors, VMs):
opennebula 5.8.4 with vcenter 6.7

Steps to reproduce:
a freshly installed system
Current results:

Expected results:

Could you try again and attach oned.log?

The problem boils down to naming. Is it turn out, that the workaround to each vm i cant import, is to rename it to a very simple name like “testvm”, then i can import, and change the name back to the original. Looks like a bug.

Could you give us an example of a vm name that you cannot import?

hi. i eventually found out that i can import almost everything from the cli. but from the web, only simple names work. say if i want to import a vm called “Server 2012R2 - Cluster”, it will fail
but from cli it will work. or if i change it to “test” or “testvm” or something very simple, it’ll work from the web as well

Hi, I’ve tried to import a VM with the name “Server 2012R2 - Cluster” from sunstone (web interface) and it works in version 5.8.4.
Also i’ve tried some VMs with complex names and i couldn’t reproduce the issue.
Are you working with 5.8.4 version?

My vCenter version is: