OpenNebula 4.14 unable to import existing VMs

Hello, i registered my vcenter cluster into Opennebula, i would like to import some VM but the “wilds” link not showing any VM to import, i followed this link on youtube:
Why i cannot see any VM ready to be imported? there’s some special setting for Vmware Vcenter Hosts ?

Hi serverx,

Under your oned.conf file did you activate the vcenter drivers?


hello yes all activated…

Is the cluster in vCenter showing correctly in OpenNebula, in the ON state?

What are the names of the wild VMs in vCenter?

yes in OpenNebula the vCenter status is ON, under the tab wild i cannot see any VM

Checked now… in my /etc/one/oned.conf this is enabled:

IM_MAD = [
name = “vcenter”,
executable = “one_im_sh”,
arguments = “-c -t 15 -r 0 vcenter” ]

VM_MAD = [
name = “vcenter”,
executable = “one_vmm_sh”,
arguments = “-p -t 15 -r 0 vcenter -s sh”,
default = “vmm_exec/vmm_exec_vcenter.conf”,
type = “xml” ]

hello, I tried also from cli…

[oneadmin@cloud one]$ onehost show 1


                      NAME                            IMPORT_ID  CPU     MEMORY


ID USER     GROUP    NAME            STAT UCPU    UMEM HOST             TIME

so nothing to import… in my test cluster i have about 200 VM
any help ?


Hello Tino, may u help me with This issue ?
maybe there’s a way to import manually the VM from vcenter to opennebula ?

Are the VMs running within a resource pool in vCenter?

yes all VMs running within several resource pool

Please remove the VMs from the resource pool and try again. Please let me know if that works.

Hello Tino, worked…
tell me somethingelse, the imported VM have no VNC icon something to enable ?

Yes, please read the following section:

How to remove resource pool on vms