[SOLVED] Re-import VM to Opennebula from vCenter

I have VM restored from backup. In vCenter VM works fine but Opennebula can’t see this VM. What I need to do for import this VM?
P.S. Sorry for my English.

Can you see the VM in the Wild tab of the Host representing the vCenter cluster in OpenNebula? If so, you can try with the import functionality.

Hello! No, after restore from backup I don’t see VM in Wild tab.

Hi Anton!
as Tinova says, if you restore a VM in vCenter from a backup the VM could be found under the Host representing the vCenter cluster in OpenNebula in the Wilds tab but if that VM wasn’t previously managed by OpenNebula.

So, the VM could also be in the Zombies tab. A VM was previously managed by OpenNebula if the recovered VM has the one- prefix in VM’s name. If the VM is in the zombies tab, Zombie VMs are meant to be a warning of VMs that need manual clean-up, so they cannot be re-imported right away. If you are sure that you want to reimport it in OpenNebula:

The following actions should be done from vCenter to recover a Zombie VM (proceed with caution):

  1. Ensure that VM is not running in vCenter as you have to change some settings.
  2. Rename the VM and remove the one- prefix from its name.
  3. Go to the Manage tab for your VM, choose Settings and VM Options. Edit the VM Options under Advanced using the Edit Configuration button.
  4. Set the opennebula.vm.id and opennebula.vm.running with an empty string so they are removed. Any opennebula.* option should require an empty value so OpenNebula doesn’t assume it’s a zombie.
  5. Also you may have to change the VNC port number in the remotedisplay.vnc.port. For example, it it’s set to 5908, that means that the VMID used in OpenNebula would be 8, so if you have that VMID in your OpenNebula’s VM list it would have a conflict so you would need to set a different VNC port before importing it.

Once you’ve done the previous steps and after some minutes (when the cluster is monitored again) you should have your VM in the Wilds tab and then you should be able to import it again.


Thanks!!! Everything worked out!