vCenter :: Restore VM

Hi folks,

In my several tests, I tried simulate a VM backup and restore, but I did not had success in this process.

Could someone please give us the right steps!?

My steps were:

  • Create a VM using Sunstone
  • Backup the VM using Veeam Software through vCenter
  • Delete the VM using Sunstone
  • Restore VM previously backuped using Veeam Software

After this point using Sunstone, can’t see it on Wilds, I tried rename it by vCenter but no way to “import” it using Sunstone.

Any tip!?

Best regards,


After, second restore, reanme-it I can see the new item in Zombies tab. But no sucess on import the VM.

As sshot attached.


Hi Carlos,
I have no previous experience dealing with Zombies VM, which I think are defined as VMs that were launched with OpenNebula but, for whatever reason, OpenNebula is not aware of this, e.g having different OpenNebula installations…

As another Carlos :smiley: explains here:

…if the problematic VM was called one-* you may change its name in vCenter and try to reimport it but I think it’s not the case. As it’s not using the default one- prefix, was the Ubuntu1404 VM a wild VM imported to OpenNebula?

I’m just guessing… if it was an imported VM maybe there’s an entry in the database refering to that Ubuntu VM and that prevents it to be reimported and that’s why it’s shown in the Zombies Tab.

According to docs imported VMs have limitations (can’t be recovered, recreated, undeployed, migrated, stopped…) so perhaps that’s the way it should be and the backup method you proposed is not suitable for this kind of VMs… hope some user can provide its experience in backup and restoring.


Hi Miguel,

First, thank you by your time for answer me :slight_smile:

I already try “rename” it, as you coudl see im my screenshot “Ubuntu1404_x864_” but no sucess on re-import it. This vm does not appear on Wild tab.

Well, how is the best way to provide backup/restore from these VMs?

Best regards,


Ups, yes you’ve renamed it sorry :blush:

Then in vCenter, as proposed in the vOneCloud forum…, try to “Remove the following entry from the VM advanced configuration:”. Maybe that’s what is telling OpenNebula that the VM is a Zombie… I haven’t tested so I’m not sure if it’s safe to do this so proceed with caution!

But as stated before… maybe another user can provide info about a proper backup/restoring VM method with vCenter.


Hey Miguel,

Even changing this value or deleting opennebula.* entries, the VM still is identified as Zombie and does not appear on Wilds screen,