Oracle Linux VM on conversion changes NIC

Please, describe the problem here and provide additional information below (if applicable) …

We have a vApp running absolutely fine in vCD. In order to move it to OpenNebula (ON), we converted the image successfully. However, when we instantiate VM out of the template in ON, it has some issues with the network service as whole. There are few changes in the converted image.

  1. if we run ‘ip addr’ cmd, it reflects ‘eth0’ and ‘lo’. However, if we go to default network location i.e. /etc/sysconfig/network-scripts/, we find the nic available is ‘ifcfg-ens192’. So when we try to update the IP address, its somehow not related since the ip addr cmd picks up the name eth0. Also, when we cross checked how it is configured in vCD and it shows ‘ens192’ in both the locations i.e. under /etc/sysconfig/network-scripts/ and by running ‘ip addr’ cmd.

  2. When we try restarting networking service, it fails with message ‘Failed to start LSB: Bring up/down networking’.

**Versions of the related components and OS (frontend, hypervisors, VMs):
FE: Linux 3.10.0-514.el7.x86_64
Hypervisors: KVM
VMs: Oracle Linux Server v7.4

Steps to reproduce:
tried to convert a new image with the same issue and even tried changing network settings

Current results:
nic card changes from ens192 to eth0

Expected results:
we need ens192 to reflect and adapt the network config set.